Beiträge von Humaxx

    Hmmm Statistiken sind so ne Sache, kann ja auch sein, dass in den letzten Jahren mehr Seagates und WDs verkauft / eingesetzt wurden,logischerweise fallen dann auch mehr aus!? Ich hab hier in meinem 2. PC grad vor nem halben Jahr noch ne 250GB (BJ 2004) und 500GB (glaube 2006) Seagate ausgebaut. vorher diverse tools drübergelaufen lassen, die waren TipTop. Und meine 2 Wochen alte Toshiba SSD (hier für OMV zugelegt) hat gestern den 1. defekten / oder schwebenden ( weis ich jetzt nicht ganz genau) angezeigt...

    Hallo, folgende Fehlermeldung erhalte ich beim booten. Scheint nicht weiter zu stören, aber wenn ich sie beheben kann würde ich es gerne tun...
    Google bringt mich aber nicht weiter...

    Hallo, habe gestern in OMV über die Aktualisierungsverwaltung alle verfügbaren Aktualisierungen aufgespielt. Funktionierte allerdings nur einzeln nach einander, alle auf einmal so wie ich es sonst mache klappte nicht.
    Lief soweit alles gut. Irgendwann am Abend NAS heruntergefahren und paar Minuten später neu gestartet.
    OMV wollte nicht mehr booten --> Datenträger (Datenfestplatte) enthält ein fehlerhaftes Dateisystem. (Die Platte ist neu, ca 4 Wochen, allerdings recertified). Hatte ich ja kürzlich schon mal... Also Platte abgeklemmt und in der fstab die Platte ausgetragen, allerdings auf die schnelle nicht richtig geguckt und die falsche Platte ausgetragen, beim nächsten Start war dann die fstab leider nur noch lesend zu öffnen?!, Naja auf ejden Fall jetzt wieder OMV neu installiert. danach die defekte Platte angehängt. In OMV folgenden SMART - Werte bekommen, sie dazu auch Anhang1, mittels Konsole fcsk gestartet, siehe die weiteren Anhänge. Fcsk ist jetzt fertig, nach erneutem check mit fsck erhalte ich jetzt das die Platte 'Sauber' ist nach neustart startet OMV jetzt wieder.


    Also jetzt die Fragen:
    1) Der 'Defekt' der Platte kann ja nicht mit den Aktualisierungen zusammenhängen oder?
    2) Ist die Platte noch zu gebrauchen?

    Danke mal für die Rückmeldungen


    1) Habe kiTTY probiert, für OMV über SSH gefällt mir das besser, da ich in der Config gleich Anmeldename und Passwort eingeben lassen kann, was mir zusagt :thumbup: - oder sollte ich das lassen??? Für die Anmeldung an meinen Receivern über Telnet gefällt mir PuTTY besser, da ich hier den Anmeldenamen gleich mit Angeben kann. In Kitty funktioniert das mit Telnet nicht?!
    2) Was ist da unsicher, kenne mich da leider nicht aus? Läuft doch alles nur in meinem Heimnetz ab oder?
    Habe mit auf meinen [definition=40,0]Windows[/definition] Rechnern Netzlaufwerke zugeordnet (mit Samba-Freigabe) allerdings ist da der Nachteil, dass wenn ich den PC heruntergefahren habe in OMV mit 'smbstatus' immer noch ne ganze Weile verbunden bin (teilweise schon 30 Minuten), was bei OMV das Autoshutdown-Plugin am herunterfahren hindert. Bei meinen Linux - Receivern (enigma2) ist die Samba - Freigabe, nach ausschalten gleich weg?!. Auch wenn ich Kodi auf den LinuxReceivern beende ist der smbstatus 'sauber', das kann Linux wohl deutlich besser als [definition=40,0]Windows[/definition]!
    3) Wie unter 2 geschrieben die Netzwerkfreigaben im [definition=40,0]Windows[/definition] mittels Samba, sind noch ne Weile aktiv nach dem herunterfahren, werde das mal mit ner NFS Freigabe testen, wobei du schreibst das ist nicht so sicher?! ?(
    4) Ja habe Kodi jetzt mal auf meinen Receivern und PCs laufen, da sieht schon gut aus..., muss mir noch noch überlegen wie ich meiner Regierung bei bringe, dass sie jetzt auf dem Receiver anstatt Knopf A Knopf B drücken muss um ihre Filme etc. zu sehen :D



    @ b0mb: emby schaue ich mir mal an, falls ich nach den weiteren Tests nicht zufrieden bin, danke für den Tipp

    Hallo, im Log von MiniDLNA steht:
    Warning: Inotify max user watches (8129) is low or close to the number of used watches (2). Und dann noch dass keine Berechtigung vorliegt dies zu beheben und ich es manuell machen soll. habe die entsprechende Datei zum Editieren gefunden, würde aber vorher gerne wissen was mir die Fehlermeldung sagen will und auf welchen Wert ich dann hochsetzen soll?

    Hallo, vielleicht könnt ihr mir ein paar Tipps geben, welcher Dienst / welches Plugin am besten für die verschiedenen Zwecke geeignet ist. Ich schreibe mal auf, welche ich bisher benutze und ihr könnte mir vielleicht sagen ob es evtl bessere Alternativen gibt.


    • Für interne Dateioperationen auf dem NAS bzw. angehängte USB - Platten nutze ich putty und den Midnight Commander. Funktioniert gut, bin ich mit zufrieden. :)
    • Dateioperationen übers Netzwerk benutze ich FTP, Funktioniert gut, bin ich mit zufrieden. :)
    • Filme auf meinen Receivern mache ich per NFS-Freigabe, Funktioniert gut, bin ich mit zufrieden.
    • Filme / Musik / Bilder am PC

      • per FTP, funktioniert zwar, ist aber bei Filmen nicht sehr zufriedenstellend, da anscheinend der Film erst irgendwie noch temporär abgespeichert wird und es somit auch mal 2 Minuten dauert bis der Film anfängt
      • per MiniDLNA, funktioniert besser, da kaum / keine Wartezeit, allerdings sind sehr viele Ordner zum Durchhangeln, was auch wieder nervig ist, kann man das irgendwo einstellen. Denn Eigentlich habe ich meine DLNA Freigabe und darin noch ein Unterordner, aber wenn ich im [definition=40,0]Windows[/definition] Explorer unter Netzwerkadressen MiniDLNA Server on OpenMediaVault öffne, muss ich um Musik zu hören noch in den Ordner Musik, dann Ordner, dann wieder Musik und erst dann bin ich im eigentlich freigegeben Ordner. Ausserdem wenn ich meine Bilder auf diese Weise öffne, kann ich nicht einfach auf den Pfeil nach rechts klicken um das nächste Bild in der Liste anzusehen.

    Im Grunde hab ich nicht viel gemacht, würde es eher allgemeine Einstellungen nennen--> Die Freigaben, 1 Benutzer angelegt. FTP, NFS Freigaben, Autoshutdown. MySQL, Plex hab ich nicht.
    Naja vielleicht ist deine Idee doch besser ;) Im Grunde verändere ich mein System ja jetzt nicht mehr großartig. Dass heisst ich müsste nur ein neues Backup erstellen, wenn ich auch tatsächlich was verändere oder?
    Bei [definition=40,0]Windows[/definition] hab ich ganz gerne neu installiert, damit der ganze Mist weg war den man so nach und nach mal drauf gepackt hat...

    Ok, klingt, als wäre das nicht wesentlicher schneller als die komplette neuinstallation?
    Bin jetzt gerade bei der Sicherung, steht aber schon ca. 15 Minuten bei dem selben Eintrag, heisst das das Backup ist fertig?

    Also die Swap - Partition soll nicht deaktiviert werden, dies ist nur eine Empfehlung um die SSD vor zu viel Schreiblast zu bewahren und ist nicht mit dem Ruhezustand kompatibel.
    Das Flash-Speicher-Plugin nutzt die swap bei genügend Speicher sowieso nicht (ausser für den Ruhezustand).


    Hier der LINK zum Thread.


    2 Fragen noch:
    1) Ich dachte das Plugin wäre eher für die USB Sticks gedacht, aber anscheinend auch für SSDs. Also nutzt ihr das Plugin mit SSDs oder empfehlt ihr es?
    2) Ich zweifle langsam meine Entscheidung an einen SLC Stick gekauft zu haben, aber mal sehen wie lange es gut gut. habe jetzt mal ein Backup des Systems gemacht. Wenn der Fall eintritt, wie läuft das dann ab, sprich wie bekomme ich die Sicherung auf die dann neue SSD?

    So gesagt getan, die Swap wieder "aktiviert" Flashspeicher-Plugin deaktiviert nun geht der Ruhezustand.
    Aber so wird der Stick wohl nicht lange mit machen oder? Habe jetzt erstmal wieder herunterfahren im Autoshutdown gewählt, Flashspeicher-Plugin aktiviert und die swap wieder auskommentiert.

    Nabend, kann ich mich mit meinem ähnlichen Problem hier anhängen oder solls ein neuer Thread sein?


    Wie 'Christine' habe auch ich das NAS Advanced nachgebaut, ebenfalls mit 4GB RAM. Als Systemdatenträger ein SLC - Stick.
    Ich habe das Autoshutdownplugin konfiguriert um damit den PC komplett herunterzufahren, was auch funktioniert, nur manchmal bootet es sofort wieder, egal ob ich per Befehl oder über OMV runterfahre. Ich behebe das in dem ich das Netzteil ausschalte in dem Moment als das System runtergefahren ist und Lüfter etc. aus sind. Wenn ich danach den Netzschalter wieder anmache und anschließend manuell hochfahre, kann ich wieder wie gewünscht das System herunterfahren und es bleibt dann auch aus. Ich habe heute auch mal nach dem Bios geguckt. Bei mir war Version 0407 (welches auf Asustek gar nicht mehr angezeigt wird?! von 2015) drauf, habe jetzt mal Version 2001 vom September 2016 aufgespielt, mal sehen wie sich das anlässt. Das rate ich auf jeden Fall auch 'Christine'.
    Nun zu meinem Problem, wollte heute mal den Stromverbrauch im Ruhezustand anschauen und habe im Autoshutdown von 'herunterfahren' auf Ruhezustand' gewechselt. Die Aktion wird wohl wenn ich die Logs richtig lese auch ausgeführt, allerdings tut sich nichts. OMV läuft einfach weiter. Woran kann das liegen? Ich kenne mich zwar nicht aus, könnte mir aber aufgrund einer Meldung im Log vorstellen, dass es mit dem Flashspeicher-Plugin zusammenhängt...
    Als Meldung bekomme ich '[1236.225066] PM: cannot find swap device, try swapon -a' und ' [1236.225123] PM: cannot get swap writer.
    Habe ja wie es im Flashspeicher-Plugin steht die swap Partition in der fstab auskommentiert
    Ist das also der Fehler, aber was kann ich da tun, wenn ich Flashspeicher-Plugin deaktiviere ist wohl bald mein Stick hin, lasse ichs, kann ich nicht in den Ruhezustand?
    Kann ich einfach die Swap-Partition die Auskommentierung wieder weg machen oder arbeitet dann das Flashspeicher-Plugin nicht richtig?

    ALso habe jetzt mal in der ezc/openmediavault/config.xml geschaut, da sind auch noch Einträge drin, kann ich die löschen oder geht dann nix mehr?Kann es sein, das OMV dann die fstab neu schreibt (wann?)
    Also in der config steht sowas z.b...


    Und diesen Eintrag auch:

    XML: config.xml
    <mntent>
            <uuid>1cf79e91-fd44-486a-89b3-8344b1dffd93</uuid>
            <fsname>/media/3f80f6f0-684b-47d2-9ad2-5b9f5062a956/Serien</fsname>
            <dir>/export/Serien</dir>
            <type>none</type>
            <opts>bind</opts>
            <freq>0</freq>
            <passno>0</passno>
            <hidden>0</hidden>
          </mntent>

    Also die ersten beiden Einträge würde ich löschen und den dritten hier dann bearbeiten von Serie auf Serien


    XML: config.xml
    <mntent>
            <uuid>4e19a1e5-d716-4729-b59b-3907be030a68</uuid>
            <fsname>/media/9449d052-0f63-460c-b252-45cf18718068/Serie</fsname>
            <dir>/export/Serie</dir>
            <type>none</type>
            <opts>bind</opts>
            <freq>0</freq>
            <passno>0</passno>
            <hidden>0</hidden>
          </mntent>

    Also folgende Fragen:
    1) Schreibt omv (config.xml) die fstab neu?
    2) Wenn ja - wann?
    3) kann ich die config einfach ädern, d.h. die Einträge löschen und bearbeiten wie beschrieben oder startet dann omv nicht mehr, backup von der config hab ich schon mal gemacht. Kann es eh erst heute abend testen

    Hallo, bräuchte doch noch mal Hilfe. Irgendwie überschreibt sich die fstab immer mal wieder und stellt die alten Einträge her, sodass meine Receiver den Ordner Serien nur leer angezeigt bekommen.
    Das hier ist die fstab wie sie sein soll. Die Einträge in Zeile 16 und 18 sind alte Einträge die sich leider irgendwie immer mal wieder selbst schreiben (d.h. wenn ich sie gelöscht habe sind die Einträge wieder da, wenn ich sie auskommentiert habe ist die auskommentierung wieder weg...) , wann dies geschieht kann ich nicht sagen...
    In Zeile 16 ist der Eintrag eines USB Sticks, der nicht mehr am NAS hängt und Zeile 18 ist eine kaputte Festplatte, die auch nicht mehr eingebaut ist.
    Die Zeile 9 und 11 wurden wie in der Beschreibung vom Flash-Speicher-Plugin angegeben geändert. Diese Änderungen bleiben auch dann bestehen, wenn sich die 'alten' Einträge in der fstab wieder herstellen.
    In OMV unter Reale Festplatten und unter Datenspeicher sind nur noch meine 3 aktuellen Laufwerke (SLC Stick mit OMV und 2 4TB Datenplatten) aufgeführt.
    Ich frage mich also in welcher Datei diese alten Einträge noch stehen, damit ich sie endgültig löschen kann.


    Die Zeile 19 wird dann auch immer geändert und sieht dann fälschlicherweise so aus. ( Den Eintrag hatte ich mal erstellt um zu testen ob meine Receiver so den Ordner Serien mit Inhalt angezeigt bekommen - was auch der Fall war.)


    Code
    /media/9449d052-0f63-460c-b252-45cf18718068/Serie /export/Serie none bind 0 0

    Die Datei exports ist richtig und siegt so aus:


    Code
    # This configuration file is auto-generated.
    # WARNING: Do not edit this file, your changes will be lost.
    #
    # /etc/exports: the access control list for filesystems which may be exported
    #               to NFS clients.  See exports(5).
    /export/Filme 192.168.178.37(fsid=1,rw,subtree_check,secure) 192.168.178.41(fsid=1,rw,subtree_check,secure)
    /export/Serien 192.168.178.37(fsid=2,rw,subtree_check,secure) 192.168.178.41(fsid=2,rw,subtree_check,secure)
    # NFSv4 - pseudo filesystem root
    /export 192.168.178.37(ro,fsid=0,root_squash,no_subtree_check,hide)
    /export 192.168.178.41(ro,fsid=0,root_squash,no_subtree_check,hide)