Beiträge von ***elvis***

    Perfekt, Lösung in dem Link gefunden. Danke.


    Für den, der nicht suchen will:


    Code
    nano /etc/avahi/services/smb.service

    Anpassen, Server neu starten und die SMB-Freigabe wird ohne " - SM/CIFS" angezeigt.

    Das ist ganz und garnicht unnötig.


    Damit kann man einstellen das der Server ohne den Zusatz z.B. "- SMB/CIFS " angezeigt wird.


    Wie man hier sieht, "NAS" ist OMV5 und der Backupserver "SRVBackup"ist noch OMV4. Da konnte ich das über "Service Discovery" einstellen das nur der Servername angezeigt wird.


    Das würde ich auch gerne in OMV5 machen.


    Ich habe hier eine HDD aus einer OMV installation an einen anderen Ubuntu Rechner angeschlossen. Die HDD wird erkannt und der erste Ordner wird angezeigt. Allerdings mit einem Schloss. Ich habe von diesem Ubuntu System kein Zugriff auf die Daten. Was muss ich tun um Zugriff zu bekommen?


    DANKE

    und was sagt jetzt mdadm --detail /dev/md0 bzw. mit md1?

    Der erste Befehl ging.


    Der zweite:

    Code
    mount /dev/md0 /mnt
    mount: wrong fs type, bad option, bad superblock on /dev/md0,
           missing codepage or helper program, or other error
    
    
           In some cases useful info is found in syslog - try
           dmesg | tail or so.

    mdadm --detail /dev/md0 bzw. mit md1



    und wieso hast du nicht gleich geschrieben, dass du mit diesen Platten ein RAID betreibst (welche Art ist dein RAID?). Das ist doch essentielle Information für deinen Fehler und unsere Glaskugel hat uns das nicht verraten.


    mach mal diese Ausgaben mit--detail, damit wir noch mehr sehen.
    eventuell kannst du ja auch einfach mal versuchen, das RAID händisch zu starten.

    Sorry, das war mir nicht so bewusst. Ist schon länger her wo ich das System eingerichtet habe. Wenn ich dran gedacht hätte, hätte ich das natürlich gleich geschrieben.


    Wie konkret heißt der Befehl "--detail"


    Wie kann man das Raid händisch starten?


    DANKE für die Hilfe

    wobei ? ein a, b, c und d sein kann (alle diese Platten haben keine Partitions).

    Das Problem ist:



    Code
    $ cat /proc/mdstat
    Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] 
    md1 : inactive sdc[0] sdd[1]
          6348646400 blocks super 1.2
    
    md0 : inactive sda[0] sdb[1]
          6348646400 blocks super 1.2
    
    unused devices: <none>
    $

    Geht dann dein Reparaturversuch auch?

    sieht für mich aus, als hättest du die beiden Drives bzw. Partitionen umbenannt ...

    Das ist korrekt so, eine HDD wurde als "Backup" und eine HDD als "BackupB" konfiguriert.



    Ich habe hier ein OMV mit mehreren HDDs als Backupserver konfiguriert. Jetzt habe ich ein Update durchgeführt und danach das System neu gestartet. Nach dem Neustart waren plötzlich HDDs nicht mehr da.


    Die Festplatten werden unter Laufwerke in OMV ganz normal angezeigt. Unter Dateisysteme sind die Laufwerke Status "Fehlend". lsblk zeigt das keine Partitionen da sind ;(


    Gibts ne Chance da was zu retten? Natürlich hab ich da gerade da was, was ich benötige.


    Mein OMV bietet mir nicht die Gruppe ftp.


    Meine LÖSUNG:
    **************


    Neue Gruppe "ftpuser" anlegen, Berechtigungen für den entsprechenden Ordner setzten


    /etc/proftpd/proftpd.conf editieren


    Folgendes ergänzen:


    <Limit LOGIN >
    DenyGroup !ftpuser
    </Limit>


    Jetzt den Server einmal stoppen und wieder starten mit:


    /etc/init.d/proftpd stop
    /etc/init.d/proftpd start


    Damit dürfen sich jetzt nur noch die Mitglieder der Gruppe "ftpuser" am ftp-Server anmelden. Bei den anderen sagt FileZilla:


    Antwort: 530 Login incorrect.


    Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen

    Für FTP habe ich einen eigenen Benutzer angelegt und nur der soll auch ftp Benutzen dürfen.


    Wo kann ich einschränken, das die anderen Benutzer FTP nicht nutzen können. Aktuell ist es dummerweise so das auch andere Benutzer FTP dürfen. Das ist natürlich suboptimal.


    DANKE

    Danke für die Unterstützung Ich habe nun doch einen anderen Ansatz versucht und bin endlich erfolgreich gewesen. Freenas und Nextcloud Plugin.

    Falls Du doch OMV willst. Hier ist eine detaillierte Komplettanleitung

    Externer Inhalt www.youtube.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.


    OMV, Benutzer, SMB / Freigabe, Nextcloud inkl. Datenbank etc., externer Aufruf über Domain, Letsencrypt für https und in einem weiteren Video Onlyoffice Server

    Was du hier machen könntest: einen USB3 auf M.2 Adapter einsetzen, um den SATA-Port frei zu bekommen ...

    USB 3 ? Die Gen7 also N36L/N40L/N54L hat nur USB 2 Dazu müsste ich noch eine USB Karte verbauen.


    Ich hab das jetzt so gelöst, das das System auf einer SSD über den internen USB Port mittels USB -> SATA Adapter läuft. Die SSD liegt unterhalb des 5,25 " Laufwerkes bei den Stromanschlüssen.


    Im 5,25" Fach ist eine weitere HDD die ist angeschlossen an den zusätzlichen internen SATA Port. Eine weitere 2,5" HDD ist ebenfalls in den 5,25" Schacht. Diese ist dann ebenfalls über USB angeschlossen, also wieder mit einem USB -> SATA Adapter. Diesen habe ich durch die Slotblende in den Innenbereich geführt.


    So habe ich sechs Datenfestplatten und eine Systemfestplatte. Das System läuft einwandfrei, flüssig, auch Lüftung ist okay. Die HDD Temperatur liegt bei 31 Grad im Leerlauf.