DDCine S2 + M.2 NVMe Hardware Überschneidung

  • Guten Morgen,



    ich bin etwas frustriert mit meinem Setup. Verbaut ist ein X11SCA-f Mainboard, darauf



    Slot 1 - PCI Card für 4 zusätzliche USB 2 Anschlüsse
    Slot 6 - DDCine S2
    Slot 7 - PCIe Card für 4 zusätzliche S-ATA Anschlüsse



    M.1-M2 - 1TB NVMe SSD
    M.2-M2 - 500GB NVMe SSD



    nun habe ich Probleme mit der DDCineS2 und dem M.2-M2 Anschluss. Es funktioniert immer nur einer von beiden.


    Im Handbuch steht:

    Expansion Slots
    • Two (2) PCIe 3.0 x16 slots (PCIe Links is NA/16 or 8/8)
    • One [Slot 2] (1) PCIe 3.0 x4 slot (shared with M.2-M1)
    • One (1) PCIe 3.0 x1 slot
    • One (1) PCI 33 MHz slot
    • Two (2) M.2 M-key sockets
    • One (1) M.2 E-key socket (for WiFi and bluetooth; X11SCA-W only)
    • One (1) U.2 slot (shared with M.2-M2)



    Deswegen habe ich die DDCineS2 von Slot 2 zu SLot 4 umgezogen. Aber nun ist das Problem wieder da. Was kann ich tun? Wie finde ich den Fehler?


    Ich lasse TVHeadend in eienm Docker Container in OMV5 laufen. Bekomme nache ienm Neustart aber die Meldung



    Failure Error response from daemon: error gathering device information while adding custom device "/dev/dvb": no such file or directory



    ich habe mal zum testen die M2 Karte raus genommen und schwups ist die TV Karte wieder da.
    Also gibt es da eine Überschneidung. Sowohl auf Sockel 4 als auf Sockel 6 wird die TV Karte nur erkannt wenn ich die M2 raus nehme. Laut Handbuch kann das eigentlich nicht sein.Besteht die Möglichkeit das nicht genügend Saft zu Verfügung steht? Muss ich also die TV karte separat mit Strom versorgen?


    Danke für Eure Zeit und Mühe
    LG
    Matt

  • hast du DDCineS2 schon mal in Slot 7 probiert und dafür die SATA Erweiterungskarte in Slot 4 bzw. 6?

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • die System SSD an einem Erweiterungscontroller ist aber ungewöhnlich.
    es sollte sich aber nichts an den Devices ändern, bzw. OMV verwendet für viele Mount Points nicht die Device Names, sondern LABEL bzw. UUID.


    war nur eine Idee, um weiteres auszuschliessen.
    bevor du umbaust, was sagt eigentlich lspci? wird dein DDCineS2 gefunden?

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • @wtuppa


    die 8 S-ATA ports sind mit den 8 Slots von der Backplane vom Gehäuse besetzt.


    Ausgabe von lspci OHNE die NVMe verbunden: zeile 26



    Server ausgemacht, NVMe eingesteckt, neu gestartet, lspci: zeile 26 gefunden, ABER beim start von TVHeadend


    Failure error gathering device information while adding custom device "/dev/dvb": no such file or directory



  • also mit der zweiten NVMe SSD wird der DDCineS2 gar nicht gefunden am PCIe (von Linux aus). Dann kann es später gar nicht funktionieren, Da hast du dich irgendwie verlesen.
    was zeigt eigentlich das BIOS an, welche Devices gesteckt sind? Da sollte auch die Möglichkeit eines Scans da sein.


    hast du auch schon mal versucht die beiden SSDs auszutauschen bzw. nur die Samsung SSD zu verwenden?
    PS: ich rate derzeit auch nur rum und versuch alles auszuloten.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • wo im BIOS kann ich das nachlesen? Ich habe nix gefunden zu gesteckter Hardware.


    ich werd mal alle Variationen durch probieren und mach dann jeweils lspci. Moment


    TV Karte auf Slot 7, beide NVMe´s gesteckt, Erweiterungscontroller auf Slot 4 und das hat es gleich gebracht. Sehr seltsam. Momentan ist alles online. Wie kann das sein? Nun ja .......


    Last login: Tue Aug 4 11:53:33 2020 from 192.168.178.70
    root@Speicher:~# lspci
    00:00.0 Host bridge: Intel Corporation Device 3e0f (rev 07)
    00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
    00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
    00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
    00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
    00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
    00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller (rev 10)
    00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller (rev 10)
    00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
    00:17.0 SATA controller: Intel Corporation Cannon Lake PCH SATA AHCI Controller (rev 10)
    00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1b.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1c.2 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1c.5 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1c.6 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1c.7 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port (rev f0)
    00:1e.0 Communication controller: Intel Corporation Device a328 (rev 10)
    00:1f.0 ISA bridge: Intel Corporation Device a309 (rev 10)
    00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
    00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
    00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
    00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM (rev 10)
    01:00.0 SATA controller: Marvell Technology Group Ltd. Device 9215 (rev 11)
    03:00.0 Non-Volatile memory controller: Realtek Semiconductor Co., Ltd. Device 5763 (rev 01)
    05:00.0 Multimedia controller: Digital Devices GmbH Cine V7
    06:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
    07:00.0 PCI bridge: ASPEED Technology, Inc. AST1150 PCI-to-PCI Bridge (rev 04)
    08:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 41)
    09:00.0 PCI bridge: Tundra Semiconductor Corp. Device 8113 (rev 01)
    0a:00.0 USB controller: NEC Corporation OHCI USB Controller (rev 43)
    0a:00.1 USB controller: NEC Corporation OHCI USB Controller (rev 43)
    0a:00.2 USB controller: NEC Corporation uPD72010x USB 2.0 Controller (rev 04)
    0b:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981


    Du weist nicht zufällig wie man Signalstärke und Qualität per Terminal von einer Cine S2 abfragt, oder ? :P:D

  • freut mich, dass es jetzt so funktioniert (auch wenn du es eigentlich deine Konfiguration so nicht haben wolltest). wir haben hier schon so einiges erlebt. Da kann so einiges mitspielen, wie PCIe nicht ganz konform, Interrupts (legacy, MSI, ...), fehlerhafte Tabellen, BIOS.
    PCI und PCIe sind halt sehr komplex und jeder kocht sein eigenes Süppchen. Da stimmt das wohl, dass viele Köche den Brei verderben...
    wir hatten schon das Problem, das 2 identische Karten nicht funktioniert haben, jede einzelne für sich schon, aber beide gemeinsam nicht...


    und nein, ich kenn mich mit deiner DD Cine S2 nicht aus, hatte noch nie so eine Karte...

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!