OMV + Snapraid startet nicht mehr

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • OMV + Snapraid startet nicht mehr

      Hallo,

      ich habe mir gerade mal einen NAS gebaut und konfiguriert. Läuft auch soweit ohne Probleme. Nun lasse ich aber nichts unversucht und wollte mal testen, ob und wie gut Snapraid Daten von verlorenen Platten wiederherstellen kann. Dazu habe ich eine meiner beiden Datenfestplatten abgezogen. Wenn man das System anschließend starten will, bleibt es hängen mit dem Fehler "failed to start enable file system quotas" und auch die Webgui ist nicht erreichbar.
      Wenn ich die Platte wieder anschließe startet es wie es soll.
      Jetzt ist es zwar unwahrscheinlich, dass eine Festplatte so defekt ist, dass sie gar nicht mehr erkannt wird, aber ich denke, es sollte doch möglich sein, Daten von einer nicht mehr vorhandenen Platte wiederherzustellen.

      Habt ihr schonmal sowas getestet?

      Vielen Dank!

      MfG Jonas
    • das ist sicher kein Problem von SnapRAID.
      Anscheinend hat das System Problem mit den Quotas und einer fehlenden Platte. Sollte eigentlich nicht sein.

      Für einen einfachen Test, kannst du ja einfach mal eine Datei löschen und nachher mittels SnapRAID wieder herstellen. Ist im Prinzip dasselbe wie auch eine ganze Platte.
      SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
      MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
    • ein kompletter Startup wäre vielleicht hilfreich. auch der Inhalt von /etc/fstab. wenn du dich einloggen kannst, kannst du auch die komplette Ausgabe des Kommandos dmesg (logging des startups) ausgeben.

      wenn du Quotas nicht wirklich brauchst, könntest du diese auf deaktivieren.
      SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
      MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
    • Re,

      Jonas schrieb:

      Habt ihr schonmal sowas getestet?
      Ja ,mehrfach ... freiwillig und unfreiwillig ;)

      Das das System stehen bleibt stimmt nicht - es erwartet eine Aktion vom Benutzer (root) auf der Konsole, was in einem solchen Fehlerfall auch das Beste ist ("root weiß was er tut") ... normalerweise läuft das System nach dem Halten an der Fehlermeldung aber weiter, das dauert u.U. eine kleine Ewigkeit.

      Btw. Backup hilft.

      Sc0rp