PI-4 OMV 5.1.3-1 - HDD wird nicht erkannt!

  • Allgemein

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • PI-4 OMV 5.1.3-1 - HDD wird nicht erkannt!

    Moin,

    das ist mein erstes Projekt mit einem Raspberry und es Frustiert mich etwas.
    Ich möchte gerne einen OMV mit miniDLNA zum laufen kriegen und es soll mit zwei Festplatten laufen, eine SDD und eine HDD (2.5' ohne externe Stromquelle).
    Während die SSD ohne Probleme läuft, macht mir die HDD nur Probleme, beide Festplatten sind im EXT4 formatiert.
    Auf der Weboberfläche, habe ich beide freigegeben für das miniDLNA und das SMB/CIFS, damit ich Daten von meinem PC einfach rüberschieben kann.
    Zusätzlich habe ich auch schon FTP probiert, das gleiche, die HDD wird nicht angezeigt.

    Ich bin etwas überfordert vielleicht könnt ihr mir helfen, hab ich etwas übersehen oder sollte ich noch was ausprobieren?

    Ich hänge mal ein Bild an von Windows
    :(
    Bilder
    • HDD.PNG

      18,28 kB, 729×256, 4 mal angesehen
  • anscheinend hat eine Neuformatierung sein Problem gelöst, da er sie ja danach mounten konnte.
    Tippe mal auf eine EXT4 Formatierung mit Optionen, die am Zielsystem nicht vorhanden waren (und damit inkompatibel).
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804
  • Danke nochmals für die Antworten!

    das mounten hat soweit nicht geklappt, denn das hatte ich vorher schon gemacht und wollte nur damit sagen, das ich Zugriff habe auf die Konsole.
    Sorry für das Missverständnis wtuppa, denn sie wird mir ja angezeigt ist aber nicht ansprechbar, wie ich es ja im Bild schon gezeigt habe!

    @Sc0rp
    das spuckt er mir aus bei dem befehl(Bild), leider kann ich damit nichts anfangen!
    Bilder
    • blkid.PNG

      12,32 kB, 670×131, 3 mal angesehen
  • dieser Befehlt gibt aus, dass auf der externen Festplatte /dev/sda auf Partition /dev/sda1 eine EXT4 Partition liegt.
    wie hast du die Partition gemounted? sollte eigentlich mount -t ext4 /dev/sda1 /mnt sein. Dann sollte die Festplatte unter /mnt verfügbar sein.
    oder gibt dieser Befehl einen Fehler aus?
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804
  • ok, du bist noch nicht der Linux Freak. Der Mountpoint ist /mnt. Du kannst jetzt ein df oder ls -l /mnt machen. Dann müßten wir sehen, ob es gut gegangen ist.
    Dein mount Befehl legt die Festplatte nur unter einem anderen Directory ab, ist aber prinzipiell dasselbe.
    PS: kannst du nicht den Output von Putty hier als Spoiler hinzufügen. Ist besser zu lesen als ein PNG.
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804
  • schaut perfekt aus, die Festplatte wurde gemounted und hat ein knappes TB Platz (stimmt hoffentlich). Die SSD war ja zu diesem Zeitpunkt nicht angeschlossen, oder? Nicht das wir jetzt eine leere SSD haben (wie gross ist die eigentlich?).
    Damit sollte die Festplatte auch von OMV aus einbindbar sein. ist eigentlich OMV5 schon aus dem Beta raus?

    andere Frage:
    die Festplatte ist über USB angebunden. Welchen USB Controller (auf SATA) bzw. welche Platte hast du da in Verwendung?
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804
  • Die SSD habe ich abgestöpselt damit, die HDD ist 1tb also knapp 900gb groß und die HDD steckt in einem SATA gehäuse mit USB 3.0, die SDD benutzt auch ein SATA USB 3.0 gehäuse und ist 120GB groß.

    ich zeig nochmal ein paar Bilder, vom Webinterface

    Vielleicht habe ich was falsch eingestellt
    Bilder
    • dateisystem.JPG

      76,55 kB, 1.258×597, 3 mal angesehen
    • SMB.JPG

      62,65 kB, 1.044×715, 3 mal angesehen
  • Moin Sc0rp,

    hier was mir ausgespuckt wurde, ich hab mal jetzt beide Festplatten ran gehängt
    Spoiler anzeigen

    pi@raspberrypi:~ $ sudo cat /etc/fstab
    proc /proc proc defaults 0 0
    PARTUUID=6c586e13-01 /boot vfat defaults 0 2
    PARTUUID=6c586e13-02 / ext4 noatime,nodiratime,defaults 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that
    # >>> [openmediavault]
    /dev/disk/by-id/ata-CT120BX500SSD1_1833E15247FE-part1 /srv/dev-disk-by-id-ata-CT120BX500SSD1_1833E15247FE-part1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    /dev/disk/by-id/usb-SABRENT_SABRENT_DB9876543214E-0:0-part1 /srv/dev-disk-by-id-usb-SABRENT_SABRENT_DB9876543214E-0-0-part1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    # <<< [openmediavault]

  • Hi. Erstelle mal im OMV einen Benutzernamen, der dem deines Windows-Systemes gleicht. Und nimm auch das Windows-Passwort als Passwort des Benutzers, den du erstellt hast. Dann im OMV im Freigabeordner auf ACL klicken und diesem Benutzer Rechte gewähren. Den letzten Haken bei "Unterordner übernehmen" nicht vergessen. Vielleicht funktionierts dann schon.

    Am Windows-Rechner, bei "Internet- oder Netzwerkadresse" im Menu Netzwerkadresse hinzufügen, sollte das dann ähnlich aussehen, wie hier (natürlich mit deiner IP-Adresse und deinem Freigabeordner. Bei meinem Beispiel ist der Freigabeordner appdata.

    \\192.168.178.59\appdata

    Weder /sharedfolders/ noch die Bezeichnung der Festplatte (in deinem Fall HDD) wird als Eingabe benötigt. Einfach nur die IP-Adresse und der direkte Freigabeordner.


    LG Berti
    BS: UNRAID
    HW: MSI B350M MORTAR, Athlon 200GE, 16Gb Ram, 500 GB NVMe als Cache, 2x 8TB HDD, 2x 4TB HDD
    Docker: adguard, duckdns, letsencrypt, emby, nginx, nextcloud, owncloud, wordpress, calibre, calibre-web, 2x heimdall, glances, bitwardenrs, mariadb, phpmyadmin, openvpn, portainer
    VM: OMV5, Macinabox, Proxmox, MX, 2x Debian Server, 1x Ubuntu Server, Freenas, XigmaNAS
    Website: https://knilixblog.wordpress.com

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berti ()