omv 4 mittels rsync auf Strato-Hidrive verbinden

  • OMV4

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • omv 4 mittels rsync auf Strato-Hidrive verbinden

    Neu

    Hallo Zusammen,
    ich habe das Problem, das ich mich derzeit nicht mittels rsync mit meinem Strato-Server verbinden kann. Ich erhalte die Meldung "Host key verfication failed". Nun lese ich an verschiedenen Stellen, dass die Ursache darin liegt, das in der Datei "known_hosts" noch alte keys gespeichert sind, die gelöscht werden müssen. Dazu habe ich verschiedene Befehle gefunden, die das bewerkstelligen sollen. Aber eine Datei namens "known_hosts" kann ich nirgends finden. Sie soll sich in /etc/ssh befinden. Dort sind zwar Schlüsselpaare abgelegt aber keine Datei namens "known_hosts".

    Ich möchte in regelmäßigen Abständen rsync veranlassen, alle Dateien in meinem Freigabeverzeichnis zum Starto-Hidrive-Server zu übertragen.
    Hier meine bisherige Vorgehensweise: Unter Zertifikate habe ich einen Schlüssel namens Strato angelegt. OMV hat selbständig einen öffentlichen Schlüssel im SSH-Format erstellt. Diesen Schlüssel habe ich kopiert und in einer Textdatei zwischengespeichert. Diese Textdatei habe ich dann in meinem Strato-Account unter RSA-Schlüssel hinterlegt.
    In der Rubrik rsync lautet mein Eintrag: meinZugang@rsync.hidrive.strato.com:/users/meinZugang/Kameras

    Wer kann mir hier weiterhelfen? Unter OMV 3 habe ich mit dieser Einstellung keine Probleme gehabt.
  • Neu

    Re,

    "known_hosts" befindet sich üblicherweise in dem BENUTZER-Verzeichnis deines jeweiligen aktuellen Benutzers unter ".ssh":
    cd ~/.ssh (das ist eine "Tilde" vor dem Schrägstrich - Die repräsentiert auf der Bash das aktuelle Benutzer-Home)

    In diesem Verzeichnis findest du eine "known_hosts" ...

    Sc0rp
  • Neu

    Leider komme ich mit deinem Hinweis nicht weiter. Melde ich mich über Putty als root an, dann kann ich das Verzeichnis .ssh einsehen. Dort finden sich ein privater und ein öffentlicher Schlüssel aber keine Datei namens "known_hosts".
    In OMV ist als User "Hartmut" eingetragen. Für diesen existiert kein home-Verzeichnis und damit auch nicht das Verzeichnis .ssh.
    Siehe Dateianhänge. Was mache ich falsch?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von milseraner ()

  • Neu

    Re,

    du hast also entweder keinen "systemweiten" Benutzer angelegt ... daher auch kein Home-Verzeichnis, oder dem angelegten Benutzer kein Login-Recht mitgegeben (dann auch kein Home-Verzeichnis).

    Mit Armbian und RaspPi kenne ich mich leider nicht aus ... ich weiß nicht, ob das in Armbian@RPi genauso läuft. Theoretisch sollte es ...

    Der o.g. Fehler kommt natürlich auch, wenn es überhaupt keine Hostkeys gibt ... oder die Falschen.

    Sc0rp
  • Neu

    Re,

    meine Builds haben alle einen extra systemweiten Benutzer, als "root" auf einem solchen System Alles zu machen ist m.E.n. nämlich eine Windows-Krankheit ;) - aber ich richte den Benutzer auch nicht unter OMV ein, sondern unter Debian selber ...

    Schau doch mal in die "/etc/passwd", das da in der Zeile von "Hartmut" steht - da müsste auch der Eintrag mit der Shell drinne stehen (mögliche Werte wären dann "/bin/bash" oder "/bin/false" oder "/bin/nologon" oder i'was in der Richtung)

    Sc0rp
  • Neu

    Re,

    milseraner schrieb:

    Du hast dich vermutlich verschrieben.
    Nein, "/etc/passwd" verweist auf die Datei "passwd" im Verzeichniss "etc", wenn ich geschrieben hätte "/etc/passwd/", dann hätte ich ein Unterverzeichnis zu "etc" names "passwd" gemeint ... der Schrägstrich am Ende macht den Unterschied aus ;)

    milseraner schrieb:

    Dort ist für "Hartmut" folgendes gespeichert: Hartmut:x:1000:100::/home/Hartmut:/bin/dash
    Der Eintrag sieht korrekt aus - daher solltest du dich als Benutzer "Hartmut" (Groß-/Kleinschreibung einhalten!) auch auf der Konsole anmelden können. Schau bitte vorher in die "/etc/shadow", ob für "Hartmut" dort auch etwas gespeichert ist (da sollte der Hash des Passwortes drin sein), siehe selflinux.org/selflinux/html/nutzer_unter_linux06.html.

    Ansonsten vergib "Hartmut" ein neues Passwort (als root) und probiere es erneut (hierbei auf Sonderzeichen achten, die werden u.U. nicht richtig übernommen), ggf. einfach "Hartmut" löschen und neu anlegen - mit Debian-Bordmitteln, siehe linuxtechi.com/linux-commands-to-manage-local-accounts/.

    Sc0rp