Beiträge von tauchvogel

    Ich habe eine Portweiterleitung (80 und 443) in der Fritzbox aktiviert, damit das NAS auch bezüglich der Cronjobs aktiv werden kann.


    Wenn ich die Portweiterleitungen deaktiviere, bleibt das NAS still und leise und startet nicht . Sobald die Portweiterleitung aktiviert ist, geht es wieder los und der Ärger fängt wieder an.

    Hier noch ein paar Screenshots der Netzwerk-Einstellungen und WOL:




    Hier mal ein Screenshot der Fritzbox Portfreigabe. IPv6 ist auch aktiviert. In OMV ist es aber nicht.

    Nachdem nun Autoshutdown funktioniert, gehe ich die nächste Baustelle an.


    Ich habe den Server mit der Portfreigabe 80 und 443 aus der Fritzbox versehen. Nach kurzer Zeit startet das System. Es scheint ein cronjob zu sein. Nach einer gewissen Zeit fährt das SYSTEM wieder herunter.


    Nach etwa 5 bis 10 Minuten startete es wieder. Das hat mich stutzig gemacht.


    Durch die Größe der Logdateien, ist es nicht möglich diese hier per Codeeingabe bereitzustellen. Ich habe diese per Dateianhänge eingefügt.


    Hoffe auf Hilfe.

    Dateien

    • syslog (2).txt

      (1,89 MB, 220 Mal heruntergeladen, zuletzt: )
    • boot.txt

      (150,47 kB, 230 Mal heruntergeladen, zuletzt: )
    • autoshutdown.log.txt

      (444,22 kB, 213 Mal heruntergeladen, zuletzt: )

    Ich habe folgendes mal probiert. Fail2ban, minidlna, antivir deaktiviert.


    Dann habe ich komischerweise immer wieder mal Portainer mit dem Plex Mediaserver im Hinterkopf gehabt, dass da etwas ist, das das System wach hält.


    Ich habe Portainer mit Plex komplett deinstalliert.


    Und prompt ging nach der eingestellten Wartezeit in den Ruhestand.


    Kann es sein, dass Plex das System wach gehalten hat? Oder ein Plugin?

    wieso hast du als Ausschaltbefehl "Ruhezustand". Das klingt nicht nach echtem Ausschalten. Da legt er ein Image vom RAM auf die Disk und das hat bei dir Probleme:

    und dann geht ihm auch noch der Speicher aus...

    und damit fährt er nicht runter (Kompremmierung ist nur bis 70% gekommen). Wieso schaltest du nicht ganz aus? Ist dir dann die Hochlaufzeit zu lange?

    also wenn du bei "Ruhezustand/Hibernate" bleiben willst, entweder Platz auf der Systemdisk schaffen oder die Kompression ausschalten, falls du keine swap partition hast (oder diese zu klein ist) [ist bei dir der Fall, da er in eine Datei speichert].

    Ich möchte gerne WOL nutzen. Das heisst, wenn erst einmal jemand im internen Netzwerk auf den Server zugreifen möchte, wird dieser per WOL Befehl geweckt. Das wird in Tutorials auch empfohlen.


    Wenn der Server doch ganz herunterfährt, wie wecke ich ihn auf?


    Also wenn ich Ruhezustand oder Unterbrechen nutzen möchte, dann muss die Kompression ausgeschaltet werden?


    Eine Kompression hatte ich nicht eingerichtet. Bei der zuerst durchgeführten Debian Installation habe ich ein home Verzeichnis eingerichtet.

    Ich muss wegen der Zeichenlänge eine weitere Antwort erstellen.


    Hier mal ein Auszug des LOG-Textes von Syslog:

    irgendwie passiert da was mit deiner Netzwerkkarte. Zuerst hat er sie erkannt und alles ging gut, und dann beim (anscheinend nächsten Boot) steigt er aus, da er keine Netzwerkkarte findet. Keine Ahnung, was da passiert. Aber definitiv deshalb die rote Leuchte.

    Das kann sein, weiss ich aber derzeit nicht.


    Nun, ich habe weiter gestestet und Autoshutdown funktioniert immernoch nicht.


    Im Log des Autoshutdown, steht etwas, dass er immer wieder IPs findet, die das System wach halten: Keine Ahnung welche IPs das sein sollen.

    Was hindert das System daran?


    Hier Screenshots von den Autoshutdown Einstellungen:



    Ich habe Portainer, dort Plex installiert. Außerdem laufen minidlna, fail2ban, antivir.

    Ich habe mehrere Einträge von fail2ban im SYSLOG:

    Code
    Feb 21 19:56:27 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:56:37 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:56:47 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:56:58 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:57:08 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:57:18 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.
    Feb 21 19:57:28 debian-nas systemd[1]: /lib/systemd/system/fail2ban.service:12: PIDFile= references path below legacy directory /var/run/, updating /var/run/fail2ban/fail2ban.pid → /run/fail2ban/fail2ban.pid; please update the unit file accordingly.

    Was heisst das und wie kann ich das eventuell beheben?

    Und hier mal ein Syslog-Auszug:Feb 18 21:13:08 debian-nas cron-apt: Get:2 https://dl.bintray.com/openmediavault-plugin-developers/usul buster/main amd64 openmediavault-autoshutdown all 5.1.11 [48.1 kB]


    Warum ist da eine rote "Leuchte"?


    Hier mal ein Syslog-Auszug des Plugins:


    Bei mir funktioniert Autoshutdown nicht. Der PC geht nicht in den Ruhezustand.


    Hier ein Auszug der Logdatei:

    Was kann ich tun?

    Da ich eine de-Domain habe und diese gerne mit letsencrypt nutzen wollte, habe ich folgendes gemacht.


    Ich habe mich an dieses Tutorial gehalten: https://herrdoering.de/de/wild…sencrypt-mit-dns-abfrage/


    Es hat soweit alles geklappt. Doch der letzte Schritt, die Zertifikate in nginx einzufügen, scheint zu scheitern. Die Einträge zum Server habe ich im nginx Verzeichnis unter "sites-available" gefunden und versucht anzupassen. Es sieht im Moment so aus (Auszug vom Gesamtcode):

    Ich weiss nicht, ob ich im richtigen Verzeichnis und in der richtigen Datei bin. Denn wenn ich meine Domain per https aufrufen möchte, geht dies immer in die Hose.


    Mir ist bewusst, dass dies offtopic ist, aber ich weiss nicht mehr weiter.


    Eine andere Seite (

    Externer Inhalt gist.github.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.
    ) macht dies ähnlich, aber man soll die nginx conf Datei anpassen, daraufhin bekomme ich Fehlermeldungen von nginx, zum Beispeil dass ein reload nicht ausführbar ist.

    was man noch machen kann, ist ein VPN spannen, wie z.B. wireguard. Dies baut dann einen Tunnel zu deinem NAS auf und du kannst die Bilder/... zur Verfügung stellen. Funktioniert dann gut, wenn es sich um nur wenige (und vertrauenswürdige) Leute handelt (denen du den Tunnel installierst). Und den Tunnel starten geht einfach (ein Clock auf ein Icon), somit muss er nicht immer aktiv sein.
    Ich habe so meinen DLNA Server (Musik) am Handy zugänglich gemacht. Funktioniert prächtig und ist sicherer (ein VPN knacken ist schon schwierger als ein HTTP Server).

    Wo finde ich dazu gute und verständliche Infos? Wireguard habe ich schon einmal gehört. Ist dies besser als OpenVPN?


    Es ist irgendwie schade, dass man nur über Drittanbieter Software Filesharing betreiben kann.

    Ich habe mir, nachdem ich nun Openmediavault schon einige Zeit genutzt habe, Gedanken über diverse Dinge gemacht, die ich bisher noch nicht ganz herausgefunden habe.


    1) Absicherung des Servers: Was kann man noch außer ufw, fail2ban und Einstellungen der Portfreigaben und/oder VPN noch machen?


    2) Datenfreigaben: Ich möchte sehr gerne eine Funktion nutzen, die folgendes kann: Dateien per Link-Freigabe an Gäste (z.B. Schwiegereltern in einer anderen Stadt) zur Verfügung stellen, damit sich diese Personen Bilder und Videos der Enkel anschauen können. Gibt es einen Dateimanager, der das kann? (Leider fand ich nur Lösungen, die für [definition=44,0]Qnap[/definition] oder Synology entwickelt worden sind.)


    Es kann auch eine andere Art der Freigabe von Dateien sein, es muss aber zwingend für den Empfänger der Datei einfach sein, darauf zuzugreifen. Ohne herumfrimeln oder ähnliches.


    Ich frage mich wegen eines Dateimanagers, warum die professionellen Anbieter dies in ihren NAS-Betriebssystemen anbieten, und leider von OMV nicht.


    Wahrscheinlich kann dies Nextcloud, da bin ich mir aber nicht sicher. Auch wird in einen interessanten Artikel davon abgeraten, Nextcloud unter OMV zu betreiben. https://nachbelichtet.com/waru…-eine-schlechte-idee-ist/


    Vielleicht kann dies auch Plex? Aberda benötigt man einen Plex Usernamen, wenn ein Gast wohl irgendetwas abrufen möchte.


    Emby kenne ich nicht so gut und weiss auch nicht, ob dies auch geht.


    Eine einfache Lösung könnte mein Problem lösen und es den "Gästen" leichten Zugang auf freigegebene Dateien ermöglichen.


    Was denkt Ihr darüber?

    Ich habe mal eine Frage zu den Ordnern. Wenn ich Dateien in schon vorkonfigurierten Strukturen auf das NAS lade, werden dann von den übertragenden Daten eigene Ordner angelegt?


    Ich frage deswegen. Wenn ich in OMV Ordner, die freigegeben werden sollen, anlege, dessen Namen aber nicht mit dem übertragenden Verzeichnissen übereinstimmen, werden die Ordner dann angezeigt?


    Kann man dann, sobald das NAS WOL durchführte, auch direkt zu den Ordnern/Verzeichnissen gehen?


    Gibt es dazu weitere Infos?

    bist du der Linux Shell mächtig?
    zum Einbinden der USB Platte gibt es den mount Befehl. Das läßt sich notfalls auch über die graphische GUI machen (ich glaub da gibt es sogar ein spezifisches Plugin).
    ich verwende jedoch immer die Linux Shell.


    delta heist, dass nur neue bzw. geänderte Dateien kopiert werden. Auf Wunsch werden auch die Dateien gelöscht, die in der Source (deine USB Platte) nicht mehr existieren. Dadurch kann es deutlich schneller sein.

    Linux Shell habe ich schon genutzt. Wie rufe ich denn da OMV5 per Shell auf? Wenn ich Shell nutze, dann sehe ich immer nur den Debian Unterbau vom Server.


    Könnte man diese Anleitung auch mit der externen Festplatte durchführen: https://www.elefacts.de/test-1…eue_nas_kopieren_mit_omv5