Kein Rebuild des Snapraids möglich

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Kein Rebuild des Snapraids möglich

      Hallo Leute,

      hab leider ein Problem beim Rebuild eines Raid unter Snapraid. Da ich meinen MainServer von WHS2011 auf OMV wechseln möchte, habe ich auf einem Testserver OMV zum testen installiert.
      Hat soweit auch alles geklappt und funktioniert auch. 2 Punkte allerdings, die mir etwas Kopfzerbrechen bereiten.

      Testserver:
      Proz: Intel Core 2 Duo E8400 3,0 GHz
      Board: MSI P35 Neo
      RAM: 2 x Crucial 2GB + 2 x 1TB
      System: OMV 2.2 auf SLC-USB-Stick
      Platten: 1 x WD-Green 1TB + 1 x Samsung 1TB + 1 x Samsung 0,5TB
      Plugins: Snapraid, AUFS, USB-Backup, Antivirus

      1. Die Übertragungsrate beim Kopieren vom Rechner auf den Server ist nicht optimal. Beim WHS2011 hab ich zur Zeit 100 MB/s. Bei OMV komme ich auf ca. 70 MB/s.
      2. Habe dann einen Festplattenausfall simuliert indem ich eine Datenplatte einfach gelöscht habe. Davor natürlich ein Sync gemacht.
      Bin nach dieser Anleitung vorgegangen:
      1. NAS herunterfahren und defekte mit neuer Festplatte ersetzen
      2. Neue Festplatte unter "Dateisysteme" einrichten (Ext4), Name = Name der ausgefallenen Festplatte + Zusatz wie "Neu"
      3. Neue Festplatte unter "Dateisysteme" einbinden (siehe Bild1)
      4. Neue Festplatte in SnapRAID hinzufügen, mit "Inhalt" und "Parität" bzw. "Inhalt" und "Daten", je nachdem ob eine Paritäts- oder Datenfestplatte ersetzt wurde (Bild2)
      5. Alte (defekte) Festplatte aus SnapRAID entfernen
      6. In SnapRAID auf den Reiter "Konfiguration" wechseln und den "Aktualisieren" Button klicken um die neue Konfiguration zu laden (siehe Bild4)
      7. In SnapRAID nun auf "Werkzeuge" klicken und "Festlegen/Reparieren" auswählen (dieser Vorgang dauert ca. 2 Stunden pro 1TB Kapazität des Verbundes) (Bild5)
      Leider versagt mir Snapraid nach anklicken von "Festlegen" das Rebuild. Er meckert, dass die alte Platte nicht vorhanden ist und ich diese doch bitte wieder anschließen soll.
      Hatte folgenden

      Self test...
      Loading state from /media/2f69223f-9209-46ef-8129-910cfb4006eb/snapraid.content...
      Decoding error in '/media/2f69223f-9209-46ef-8129-910cfb4006eb/snapraid.content' at offset 143
      The file CRC is correct!
      Disk 'Daten2' with uuid 'a021e32f-4598-42c7-b0ea-9d6c4e62ffad' not present in the configuration file!
      If you have removed it from the configuration file, please restore it

      SnapraidConfig:
      block_size 256
      autosave 0

      #####################################################################
      # OMV-Name: Paritaet1 Drive Label: WD1TB1
      content /media/2f69223f-9209-46ef-8129-910cfb4006eb/snapraid.content
      parity /media/2f69223f-9209-46ef-8129-910cfb4006eb/snapraid.parity

      #####################################################################
      # OMV-Name: Daten1 Drive Label: Samsung1TB1
      content /media/802aa8c8-6894-4d91-b602-ee5d8bf2c133/snapraid.content
      disk Daten1 /media/802aa8c8-6894-4d91-b602-ee5d8bf2c133

      #####################################################################
      # OMV-Name: Daten2neu Drive Label: Daten2neu
      content /media/15a00894-ba93-4793-9b9e-710083a28905/snapraid.content
      disk Daten2neu /media/15a00894-ba93-4793-9b9e-710083a28905

      Was mach ich falsch bzw. wo liegt der Fehler?
      Möchte natürlich sicher sein, wenn ich das System auf den MainServer installiere, dass auch alles so funzt wie es soll.
      OMV-Version: 3.0.88
      Prozessor: Celeron G1840 /2,8 GHz
      Kernel: Linux 4.9.0-0bpo.3-amd64
      Snapraid / mergerfs
    • Re,

      tovaxxx schrieb:

      Problem gelöst. Die neue Platte muss den gleichen Namen haben wie die alte. Dann funktioniert auch das Reparieren des Raid.
      Muss sie nicht unbedingt, aber für das Rebuild unter OMV ist es deutlich einfacher/praktikabler - anders muss man die SnapRAID-Konfig händisch anpassen ;)

      Sc0rp