OMV5 Update Fehler

  • Heute habe ich ein Update von OMV 5 vorgenommen, das auch andere Pakete beinhaltete. Das Update startete zuerst wie gewohnt normal. Allerdings kam irgendwann in einer Dauerschleife immer wieder die folgende Meldung:

    "Failed to open file (filename=/tmp/bgstatusLMRNBo,mode=r)."


    Der Screenshot meines Smartphones zeigt dies auch.


    Ich habe nach einer Weile das Fenster geschlossen. Allerdings habe ich die Vermutung, dass das Update nun Probleme verursacht.


    Das System geht nicht mehr in den Ruhestand/Standby.


    Ich wollte noch Portainer über OMV-Extras/Docker erneuern, dies hat auch nicht funktioniert. Portainer ist derzeit nicht erreichbar.


    Was kann ich tun, damit das System seine Updates erhält, die es benötigt? Und was kann ich tun, damit es wieder normal funktioniert?


    Was kann ich mit dem Portainer Update machen?


    Bitte um Hilfe!

  • Ich würde erst einmal im Terminal folgendes versuchen:


    apt update && apt upgrade -y


    Anschließend einen Neustart:


    reboot

    BS: UNRAID
    HW: MSI B560M PRO-VDH, i5-10400, 64Gb Ram, 2x 1 TB NVMe Cache (Raid1), 2x 1TB SSD VM-Cache (Raid1), 2x 8TB HDD, 2x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VMs: OMV6, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

  • Jetzt muss ich erst mal überlegen. Welche Architektur verwendest Du? X64 oder ARM? Wie hast Du OMV5 installiert? Über ein fertiges Image oder über Scriptinstall?


    Wenn Du das fertige Image verwendet hast, dann:

    Portainer abwählen bzw. löschen. Jetzt Portainer über Docker oder Docker-Compose installieren (Ports beachten).


    Docker:


    sudo mkdir /var/lib/PortainerData


    docker pull portainer/portainer


    docker run -d -p 9002:9000 -p 8001:8000 --name portainer --restart always -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/PortainerData:/data portainer/portainer-ce



    Oder Docker-Compose:


    sudo mkdir /home/dockervolumes


    sudo mkdir /home/dockervolumes/portainer



    cd /home/dockervolumes/portainer && sudo nano docker-compose.yml


    Folgendes eintragen:


    Strg-x, y, Enter


    Start:


    cd /home/dockervolumes/portainer && sudo docker-compose up -d



    Aufruf in beiden Fällen: Server-IP:9002




    Hast Du das Scriptinstall verwendet, dann Portainer und Docker im OMV deinstallieren, anschließend im Terminal:


    apt clean


    apt update


    apt autoremove


    Jetzt erst Docker und dann Portainer im OMV wieder, in der Reihenfolge, wie eben genannt, installieren.


    Warum das Ganze? Nun, ich hatte damals mit OMV5 das gleiche Problem. Leider machte das fertige Image bei mir Probleme, wenn es speziell um Portainer ging, so dass ich seither immer das Debian installiere und dann das Scriptinstall empfehle. Portainer installiere ich bei mir immer separat per Hand, als Docker, meist als Docker-Compose-Script.


    Sorry für die etwas unübersichtliche Schreibweise. Die Codes haben sich leider nicht richtig einbinden lassen.


    LG Berti

    BS: UNRAID
    HW: MSI B560M PRO-VDH, i5-10400, 64Gb Ram, 2x 1 TB NVMe Cache (Raid1), 2x 1TB SSD VM-Cache (Raid1), 2x 8TB HDD, 2x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VMs: OMV6, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

  • Danke für Deine Infos. Soweit ich das noch weiss, habe ich OMV5 über Debian auf x64 installiert.


    Du schreibst, ich soll Docker neu installieren. Was ist mit den anderen vorhandenen Containern? Sind die dann auch weg?

  • Hab' ich noch gar nicht ausprobiert :-)


    Da ich sowieso Docker-Compose verwende, habe ich mir darüber noch nie 'nen Kopf gemacht. Ich starte einfach die Compose-Scripte und alles ist wieder da. Die angelegten Verzeichnisse, die im Compose-Script definiert sind, bleiben ja bestehen. Und das sollte theoretisch auch bei normalen Docker-Befehlen so sein. Du müsstest dann, wenn Du die normalen Docker-Befehle verwendest, diese anschließend noch einmal komplett, nacheinander, wieder starten. Auch diese angelegten Ordner sollten fest drin sein, wenn diese so definiert wurden.


    Aber wie gesagt - - Das habe ich noch nie wirklich getestet.

    BS: UNRAID
    HW: MSI B560M PRO-VDH, i5-10400, 64Gb Ram, 2x 1 TB NVMe Cache (Raid1), 2x 1TB SSD VM-Cache (Raid1), 2x 8TB HDD, 2x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VMs: OMV6, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!