OMV Webgui nicht erreichbar

  • ich würde mal sagen, dass hier der MAILer amok läuft. Schau mal in mail.warn bzw. mail.err was da schief läuft.

    syslog und mail.* haben jeweils über 5 GB.


    bzw. wird seit Mitte Mai scheint es, kein log rotate mehr durchgeführt. Dadurch werden die log files nicht mehr gezipped und gelöscht.

    mach einmal ein logrotate -f /etc/logrotate.conf, dann sollten die Log Files wieder neu angelegt werden (und alle alten gezipped sein).

    beim zweiten Aufruf sollten dann alle log files gezipped sein (die .1 Dateien sind noch in voller Größe).

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • hmmm anscheinend ist zu viel Speicher in Gebrauch als das er dies ausführen würde, müsste ich manuell irgendwas löschen, damit ein Teilspeicher leer wird?

  • dann bleibt wohl nur manuelles Löschen übrig. Aber bitte zuerst mal in die riesigen Logs reinschauen (vor allem am Ende und sich dauernd wiederholende Sequenzen). Dann finden wir eventuell raus, was da schief geht.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • ich habe mir mit less die Datei mail.warn und mail.err ausgeben lassen. Um ehrlich zu sein, ich habe keine Ahnung von der Materie.

    Hierzu ein kleiner Auszug aus mail.err (es wiederholt sich, zwei Ausschnitte dazu):

    und das Ende der Datei:

  • mail.warn:

    Vermutlich sind die Ausgaben auch zu lang aber nur weil ich nicht wirklich weiss, was nötig wäre.

  • Habe eben auch mal in die syslog geschaut.

    Da steht viel im Zusammenhang mit meiner Mailadresse, weil ich diese vermutlich nicht richtig eingerichtet hatte bzw. irgendwann vergessen hatte.

    Evtl. versucht er immer etwas an diese zu senden, ohne Erfolg...

  • klingt definitiv nach einem Problem mit der MAIL von OMV. Eventuell mal komplett abschalten oder Konfiguration korrigieren.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • Das klingt nach einem Plan.

    Wie könnt ich das abschalten, da ich nicht auf die GUI komme?

    Kann ich das über die Eingabeaufforderung lösen oder doch schon etwas manuell löschen?

  • Ich würde zwei von diesen 5GB-Mail/Log-Dateien über das Terminal löschen, dann den logrotate -f /etc/logrotate.conf - Befehl nochmal versuchen laufen zu lassen und dann wieder versuchen die GUI zu erreichen. Platz sollte dann da sein.

  • Ich verzweifel gerade, habe mail.warn und mail.err gelöscht, es ist trotzdem kein Speicherplatz verfügbar. Ich habe jetzt noch einmal df und dh durchlaufen lassen, mit keinem guten Ergebnis:

  • du hast zwar die Dateien gelöscht, sie sind allerdings im logging daemon noch geöffnet (und deshalb wird der Speicherplatz nicht freigegeben). Allerdings werden sie natürlich nicht mehr angezeigt. Ist auch ein üblicher Trick für temporäre Dateien (damit sie sicher weg sind, falls die Applikation crashed).


    Bitte einmal rebooten.

    oder die .1 Dateien löschen.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • habe die beiden .1 Dateien gelöscht und einen reboot durchgeführt:

  • komisch, was sagt jetzt ls -l /var/log/?

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • zusätzlich noch:

    Code
    root@omnas:~# df -h
    Dateisystem             Größe Benutzt Verf. Verw% Eingehängt auf
    udev                     7,7G       0  7,7G    0% /dev
    tmpfs                    1,6G    155M  1,4G   10% /run
    /dev/sde1                 43G     42G     0  100% /
    tmpfs                    7,7G       0  7,7G    0% /dev/shm
    tmpfs                    5,0M       0  5,0M    0% /run/lock
    tmpfs                    7,7G       0  7,7G    0% /sys/fs/cgroup
    tmpfs                    7,7G    780K  7,7G    1% /tmp

    Hier scheint sich das Log sehr schnell zu füllen.

    Einmal editiert, zuletzt von ddhh () aus folgendem Grund: Quellcode hinzugefügt

  • da hast du aber recht... syslog ist jetzt 9GB.

    also mal alles in /var/log löschen und dann rebooten. Und sofort die WebGUI versuchen.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • alle aktuell notwendigen LOG dateien werden wieder angelegt. das sollte reichen.

    FRAGE: wie oft hast du schon in die LOG dateien rein geschaut? was hast du daraus geschlossen?


    wenn du nicht alle willst, dann alle syslog und mail logs.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • um ehrlich zu sein, hatte ich gar nicht mehr reingeschaut bzw. auch in keiner Weise regelmäßig irgendetwas geprüft. ich fange mal mit den syslog und mailogs an.


    PS: habe es getestet, die Sachen gelöscht und trotzdem zeigt er mir bei logrotate "...kein Speicherplatz verfügbar..."; auf die GUI kann ich mich nicht einloggen - Seitenladefehler (Verbindung fehlgeschlagen)


    Code
    root@omnas:~# df -h
    Dateisystem             Größe Benutzt Verf. Verw% Eingehängt auf
    udev                     7,7G       0  7,7G    0% /dev
    tmpfs                    1,6G    8,9M  1,6G    1% /run
    /dev/sde1                 43G     23G   19G   56% /
    tmpfs                    7,7G    4,0K  7,7G    1% /dev/shm
    tmpfs                    5,0M       0  5,0M    0% /run/lock
    tmpfs                    7,7G       0  7,7G    0% /sys/fs/cgroup
    tmpfs                    7,7G       0  7,7G    0% /tmp

    Speicher sieht noch gut aus

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!