OMV Webgui nicht erreichbar

  • Moin zusammen,


    ich komme seit gestern nicht mehr auf die Webgui von OMV.

    Gestern kam über den Firefox keine Rückmeldung sondern nur wieder das Anmeldefenster und im Edge kam Timeout.

    Änderungen habe ich wenn, dann sehr unbewusst durchgeführt. :) Bzw. hatte ich letzte Woche ein paar Updates durchgeführt. (welche genau kann ich nicht mehr sagen)

    Heute habe ich es noch einmal probiert im Firefox und bekam folgende Fehlermeldung:


    Failed to connect to socket: No such file or directory


    Error #0: OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:141 Stack trace: #0 /var/www/openmediavault/rpc/session.inc(57): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true) #1 [internal function]: OMVRpcServiceSession->login(Array, Array) #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array) #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array) #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(97): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3) #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle() #6 {main}


    Ich kann über den SSH Client Console zugreifen. (root).

    Ich habe schon apt-get update/upgrade durchgeführt ohne weiteren Erfolg.



    df -h


    Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf

    udev 7,7G 0 7,7G 0% /dev

    tmpfs 1,6G 9,1M 1,6G 1% /run

    /dev/sdd1 43G 24G 18G 58% /

    tmpfs 7,7G 4,0K 7,7G 1% /dev/shm

    tmpfs 5,0M 0 5,0M 0% /run/lock

    tmpfs 7,7G 0 7,7G 0% /sys/fs/cgroup

    tmpfs 7,7G 0 7,7G 0% /tmp

    /dev/mapper/Stube-Media 5,1T 1,6T 3,5T 32% /srv/dev-disk-by-label-med

    overlay 43G 24G 18G 58% /var/lib/docker/overlay2/bffe0f8de28f733067b9c76b27735f262a3e22bb67b59737ba3b486521c47313/merged

    overlay 43G 24G 18G 58% /var/lib/docker/overlay2/595235bb2700d82dcbc37dbfc16c87ea7ef6b10c5cbe422b8ccbe9314f4d37ef/merged



    du -h --max-depth=1 /


    0 /tmp

    4,0K /dev

    1,6T /srv

    4,0K /Backup-rsync

    ^[

    31G /var

    16K /opt

    16K /lost+found

    4,0K /home

    60K /root

    3,5G /usr

    7,0M /etc

    4,0K /export

    12K /media

    0 /sys

    9,1M /run

    4,0K /mnt

    261M /boot

    du: Zugriff auf '/proc/3367/task/3367/fd/3' nicht möglich: Datei oder Verzeichnis nicht gefunden

    du: Zugriff auf '/proc/3367/task/3367/fdinfo/3' nicht möglich: Datei oder Verzeichnis nicht gefunden

    du: Zugriff auf '/proc/3367/fd/4' nicht möglich: Datei oder Verzeichnis nicht gefunden

    du: Zugriff auf '/proc/3367/fdinfo/4' nicht möglich: Datei oder Verzeichnis nicht gefunden

    0 /proc

    1,7T /


    Habt ihr eine Idee?

    Danke euch und VG

  • Hi. Schon im Terminal folgendes versucht?


    Code
    omv-firstaid


    LG Berti

    BS: UNRAID
    HW: MSI B350M MORTAR, Ryzen 3200G, 32Gb Ram, 1 TB NVMe Cache, 1TB SSD VM-Cache, 2x 8TB HDD, 1x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VM: OMV5, Macinabox, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

  • so richtig mit Quellcode?


    das ist der output von omv-firstaid

  • und hier noch einmal die Ausgaben von oben als Quellcode:

  • Das mit dem Code klappt doch sehr schön und die Ausgaben sind deutlich besser zu lesen.

    Deine root-Partition sdd1 ist voll. Jetzt gilt es zu ermitteln, warum die voll ist. Du solltest dich mit Putty oder ssh auf den OMV-Rechner setzen und den obigen Link einmal befolgen.

  • vermutlich sind die LOG files in /var/log sehr gross geworden...

    oder zu viel SW wurde installiert (inklusive die Docker Images).

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • hat es evtl. auch etwas mit dem zum o.g. Code von omv-firstaid auf Zeile 11 zu tun, dass ein Modul nicht gefunden wurde?


    Bernd, ok, den Link schau ich mir nochmal an, da kam ich noch nicht dazu.


    wtuppa: danke dir für die Info, Software ansich dürfte ich nicht so viel installiert haben. Aber was ich jetzt anhand deiner Aussage auch vorstellen könnte ist, dass es etwas mit Docker Images zu tun hat, da ich dort einiges versucht habe anzupassen, vor allem was plex docker betrifft, da dort keine automatische Aktualisierung der Version erfolgte. Ich schau mir auch mal das var log an.


    Das Thema plex hatte ich auch schon mit Berti, da hatte er mir schon empfohlen die Auslagerungsdateien nicht auf die SSD zu legen. Hätte ich wohl doch gleich mal machen sollen. :D

  • Bei mir am Raspi ging mal die Backupplatte verlustig, auf die er mit sync oder Snapshot schreiben sollte. Das Mounterzeichnis unter /srv gibt es ja weiterhin und so hat OMV fleissig das Backup auf die Systemplatte geschrieben.

    Alle umounted und die Dateien im falschen Backupverzeichnis gelöscht und es war wieder gut. Aber da muss man auch erstmal drauf kommen.

  • Code
    root@omnas:/var/log# du -a
    5220576 ./syslog
    5196520 ./mail.info
    5041320 ./mail.warn
    174200  ./syslog.1
    5393896 ./mail.log
    21524692

    das ist erstmal ein Ausschnitt vom Log Verzeichnis

  • Also nur um Missverständnisse aus dem Weg zu räumen. Das ist normalerweise die Ausgabe von omv-firstaid



    LG Berti

    BS: UNRAID
    HW: MSI B350M MORTAR, Ryzen 3200G, 32Gb Ram, 1 TB NVMe Cache, 1TB SSD VM-Cache, 2x 8TB HDD, 1x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VM: OMV5, Macinabox, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

  • Das war schon richtig. Mit ssh bist Du auf dem Server. Ich wollte Dir nur zeigen, was bei diesem Befehl normalerweise kommt. Bei Dir sind dort alles Fehlermeldungen, die da normalerweise nicht hingehören.


    LG Berti

    BS: UNRAID
    HW: MSI B350M MORTAR, Ryzen 3200G, 32Gb Ram, 1 TB NVMe Cache, 1TB SSD VM-Cache, 2x 8TB HDD, 1x 4TB HDD
    Docker: calibre-web, db-backup, duckdns, EmbyServer, glances, Grafana, heimdall, InfluxDB, mariadb, nextcloud, nginx, OpenSpeedTest, phpmyadmin, portainer, telegraf, unifi-controller, UniFi-Poller, Wireguard, WordPress
    VM: OMV5, Macinabox, Proxmox, MX, 3x Debian Server, 1x Ubuntu Server
    Website Übersicht: https://knilixblog.wordpress.com
    Website OMV5: https://knilix.home.blog

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!