OMV Pi4 Übertragung langsam

  • Hallo liebe Community,
    Ich habe hier ein kleines Problem wobei ihr mir sicher helfen könnt.


    Zu meiner Hardware:
    Pi4 mit 4Gb Ram
    2x 1Tb externe Festplatte von Seagate mit Usb3


    einen 3.0 USB hub mit Netzteil.


    Zuerst wollte ich ja beide Festplatten direkt an die Raspi schließen. Jedoch liefert sie zu wenig Strom für beide. Deshalb musste der Hub her.
    Dann war ja eigentlich mein Gedanke ein Raid aus den Platten zu machen, geht aber nicht da OMV Raid über USB nicht zulässt.(zu unsicher)
    OK denk ich mir schmeißen wir den Gedanken wieder über Board und verwende beide Platten extra.
    so eine Platte an die Raspi und eine über den Hub. Soweit so gut.
    Nur habe ich jetzt starke Performance Einbußen was den traffic angeht. mit nur einer Platte konnte ich das Netzwerk voll auslasten (ca100MB/s)
    Mit beiden Platten hatte ich anfangs auch die volle Leistung. mit der Zeit aber wird´s immer langsamer. Derzeit habe ich eine Übertragungsgeschwindigkeit von 30-35 MB/S
    Woran könnte es liegen das nix weiter geht??


    Lg
    Mario

  • gibt es vielleicht Fehlermeldungen bezüglich USB und Festplatte im /var/log/syslog. Bei manchen USB=>SATA funktioniert nämlich UAS (Usb Attached Scsi), der schnellste Mode, nicht einwandfrei. Mittels Block Listing kann man da Abhilfe schaffen.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • Guten morgen.
    Zuerst einmal ein frohes Weihnachtsfest euch allen.
    Und danke für eure schnellen Antworten.
    @wtuppa sobald es mir ausgeht werde ich nachschauen ob's eine Fehlermeldung gibt.


    @redjack Wenn ich sie einzeln direkt an die pi anschließe bekomme ich um die 100MB/S. Beide zusammen funktionieren wie schon gesagt nicht da die Stromzufuhr von da pi nicht ausreichend ist.


    @Bernd danke habe ich auch schon in Erwägung gezogen



    LG Mario

  • Wenn es am Anfang schnell ist und später mal langsamer, so liegt das nur daran, dass am Anfang die zu kopierenden Dateien einfach in den Cache geschoben werden. Wenn der voll ist, wird es langsamer und am Ende zeigt sich die Geschwindigkeit, die dein Netzwerk überhaupt kann.
    Zudem ist es ein riesen Unterschied,ob du eine 4GB-Datei kopierst oder ob du 1000 5kB-Datei kopierst. Bei den kleinen Dateien wird die Geschwindigkeit einbrechen bis in den kByte/s-Bereich hinein.
    BTW Ich komme mit meinem Raspi im Lan auf Geschwindigkeiten (am Ende) von max 35-40 MByte/sec im Lan. Im Wlan je nach Anbindung ist es deutlich langsamer. Auf welchem Weg überträgst du die Daten?

  • Hallo alle zusammen,
    Sorry die späte Antwort.
    Also im Syslog steht keine Fehlermeldung drinn.
    @Bernd Die Pi ist per Lan am Netzwerk angeschlossen. Meist sind es große Dateien die Kopiert werden. Deswegen auch meine Frage ob man das was machen kann.


    @redjack obwohl es ein USB 3 hub ist??


    Was wäre wenn ich mir richtiges NAs zusammen baue?? (mit sata anschluss usw) würde das mein Geschwindigkeitsproblem beheben???

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!