NFS mount Problem

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • NFS mount Problem

    Guten Abend,

    ich habe einen Heimserver am laufen mit Proxmox.
    Dort läuft Nextcloudpi auf einer VM. Die soll Backups auf meinem Synology NAS machen.
    Das sollte per NFS passieren. Ich schaffe es, dass ich es mounte und das Backup dort drauf spiele nur das Problem ist, wenn die Synology Neu-Startet gefriert meine VM am Proxmox ein.

    In der /etc/fstab habe ich sie wie folgt gemountet.

    Quellcode

    1. 192.168.178.212:/volume1/ncbackup /mnt/synology nfs soft 0 0
    Ist der Fehler hier begraben oder mache ich etwas anderes falsch?

    Hoffe ihr könnt mir helfen.


    MFG Schmidt
  • Neu

    wtuppa schrieb:

    welche mount Optionen sind derzeit bei dir aktiv?
    zurzeit ist nur soft aktiviert




    Sc0rp schrieb:

    Re,

    was für Backups sind das denn genau, das man dafür NFS nehmen muss?

    Ich backe jede Menge QNAPs und Syn's up ... Alles via "rsync-over-ssh" ... cronjobbed.

    Sc0rp

    auf der VM läuft Debian. Auf diesem läuft Nextcloudpi dies hilft einen laien wie mir die Nextcloud Zuhauese zu betreiben und dies leicht zu bedienen.
    Dort habe ich die möglichkeit, dass ich Backups über ein vorgefertigtes Skript machen (die Nextcloud wird in den Wartungsmodus geschaltet, alle Datenbanken und was dazugehört wird in einen .tar Ordner gepackt.
  • Neu

    daschmidt94 schrieb:

    zurzeit ist nur soft aktiviert
    und die default Optionen von NFS weiss ich leider nicht auswendig, also bitte mount | grep nfs,

    daschmidt94 schrieb:


    Sc0rp schrieb:

    Re,

    was für Backups sind das denn genau, das man dafür NFS nehmen muss?

    Ich backe jede Menge QNAPs und Syn's up ... Alles via "rsync-over-ssh" ... cronjobbed.

    Sc0rp

    "rsync-over-ssh" ist einfach, sicher und elegant, bei mehreren Dateien schneller (statt der TAR Datei), da immer nur deltas übertragen werden. falls du mehrere Backups haben willst, ist jedes mal ein TAR mit Datum sicher besser. Aber eben mit rsync-over-ssh. Mit Zertifikaten für SSH (wegen login) geht das voll automatisch.
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Neu

    Quellcode

    1. root@nextcloud:~# mount | grep nfs
    2. 192.168.178.212:/volume1/ncbackup on /mnt/synology type nfs (rw,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.178.212,mountvers=3,mountport=892,mountproto=udp,local_lock=none,addr=192.168.178.212)
    möchte schon die Daten in einer .tar Datei haben, da es dann leichter ist ein backup zurückzuspielen
  • Neu

    rsync funktioniert auch mit einer einzelnen Datei natürlich. Im Pinrzip loggt sich rsync über SSH in das Target System ein und überträgt dann die Daten. Und nach dem Transfer ist die Verbindung beendet...

    Schau dir halt mal man rsync an. Ist ein sehr gutes und mächtiges Tool bzw. diese Seite. Hier ist nett beschrieben, wie man alles unter der Synologie macht, damit sich diese das Backup mittels rsync (vom Raspi) abholt.
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Neu

    wtuppa schrieb:

    rsync funktioniert auch mit einer einzelnen Datei natürlich. Im Pinrzip loggt sich rsync über SSH in das Target System ein und überträgt dann die Daten. Und nach dem Transfer ist die Verbindung beendet...

    Schau dir halt mal man rsync an. Ist ein sehr gutes und mächtiges Tool bzw. diese Seite. Hier ist nett beschrieben, wie man alles unter der Synologie macht, damit sich diese das Backup mittels rsync (vom Raspi) abholt.

    Danke hab ich jetzt mal so hinbekommen.

    Nur das Problem ist das ich maximal eine Geschwindigkeit von 10 MB/s liegt nicht an Rsync oder.

    Sieht wie folgt aus Fritzbox über Lan Kabel zu einem Powerlin und vom 2. Powerlin zum Proxmox Server. Laut Fritzbox Weboberfläche schaffen die 2 Powerlines 200Mbit/s
  • Neu

    naja, Powerline habe ich keine Erfahrung. Aber wie riesig ist dein Backup?
    wegen Geschinwdigkeit eventuell mal mit einem frei verlegten LAN Kabel probieren, wie schnell das ist. Und nirgends dazwischen was mit 100MBit/s only?
    bei SSH kann aus der Prozessor bremsen, wenn er schwachbrüstig ist (wegen Verschlüsselung).
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Neu

    genau aus diesem Grund läuft bei mir quer durch die Wohnung an der Wand/Decke ein LAN Kabel in einem Kabelkabel entlang und verbindet die einzelnen Switches in den Zimmern (ok, nicht alle Zimmer, nur dort wo weiter LAN benötigt wird). Ist einfach stabiler als alles andere...
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Neu

    Naja bei mir ist das nun nicht mehr so leicht im -nachhinein noch ein Kabel verlegen.
    Ich verstehe nur nicht wenn der Fritz Powerlin 250Mbit/s anzeigt müsste er das ja normal auch bringen.

    Blöde frage, wenn ich die Synology neben dem Server stelle(wenn der Switch beim 2. Powerline angeschlossen wird), müsste das mit den Backups auch schneller gehen oder muss alles sowieso erst zum Modem.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von daschmidt94 ()

  • Neu

    Hi.

    daschmidt94 schrieb:

    Blöde frage, wenn ich die Synology neben dem Server stelle(wenn der Switch beim 2. Powerline angeschlossen wird), müsste das mit den Backups auch schneller gehen oder muss alles sowieso erst zum Modem.
    Jo. Müsste viel schneller gehen. Der Router vergibt nur die IP-Adressen. Alles andere regeln die Switches. Wenn du die beiden Geräte an einen Switch hast, ist das von Vorteil. Der Flaschenhals ist übrigens im Netzwerk die FritzBox. Jetzt nicht in deinem Fall (da ist es das Powerline), aber ich habe erhebliche Geschwindigkeitsschübe festgestellt, wenn du von der Fritze zum Switch gehst und dann von dort alle anderen Geräte weiter verteilst. Notfalls auch über einen weiteren Switch (also Router --> Swich --> Switch), wenn Du mit den Anschlüssen nicht reichen solltest. Ich habe übrigens 112 MBit Datenübertragung in meinen eigenen Netzwerk. Vom zweiten Netzwerk aus, welches übrigens mit Powerline verbunden ist, sind es auch nur zwischen 40 MBit und 70 MBit. Das schwankt sehr. Blödsinngerweise läuft das bei meinem Freund mit 90 Mbit bis 100 Mbit. Aber da gibt es wohl die tollsten Qualitätsunterschiede der Powerline-Adapter. Ich verwende momentan noch die AV1000 von tp-Link und er hat mittlerweile zwei schnelle Teile von Devolo.

    Bei mir wird der Powerline-Adapter aber etwas anders eingesetzt, als das bei Dir der Fall ist. Ich habe mittels Edge-Router und Powerline 2 Fritzboxen, mit jeweils eigenem Internet, intern verbunden, um vom zweiten Netz Zugriff auf meinen Server zu bekommen (vom Switch 01 zu Ubiquity-Netzwerkrouter ist bei mir das Powerline drin). Eigenartigerweise habe ich immer Nachts, wenn alle Geräte im Haushalt soweit aus sind, eine bessere Verbindung, als Tagsüber. Zu viele Einflüsse, die von störender Natur sind. Am schlimmsten ist übrigens die Mikrowelle. Läuft die, sackt die Verbindung des zweiten Netzwerkes zum Server auf 20 Mbit zusammen. Ich bin aber auch am überlegen, ob ich nicht vielleicht noch ein Netzwerkkabel von der zweiten Fritzbox zum Edge-Router lege. Erst mal die Hauptarbeiten noch erledigen. Morgen werde ich wahrscheinlich dann soweit fertig sein.

    So ähnlich, wie auf dem Bild, sieht das auch bei mir mittlerweile aus. Nur dass am Switch 001 noch 2 TV`s dran hängen. Die Verkabelung auf dem Bild hatte ich einst für einen Freund gelegt, der es immer noch so verwendet. Nur zur Info. So, wie auf der linken Hälfte des Bildes, könnte es bei Dir aussehen. Ohne das zweite Netzwerk und ohne dem Edge-Router.



    LG Berti
    BS: OMV5 auf Buster
    SW: UFS, Snapraid, LEMP, rsync, Rsnapshot, SMB/CIFS
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, Micro-ATX Gehäuse, 8Gb Ram, 64Gb M.2 SSD als Systemplatte, 64 GB SSD für Cache, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, bitwardenrs/server, linuxserver/mariadb, phpmyadmin/phpmyadmin, duplicati/duplicati
    Website: https://knilix.home.blog

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berti ()

  • Neu

    Berti schrieb:

    Ich bin aber auch am überlegen, ob ich nicht vielleicht noch ein Netzwerkkabel von der zweiten Fritzbox zum Edge-Router lege.
    Kleiner Schreibfehler. Ich meinte natürlich vom Switch 01, der an der zweiten Fritzbox (Router 01 im Bild) hängt, zum Edge-Router.

    LG Berti
    BS: OMV5 auf Buster
    SW: UFS, Snapraid, LEMP, rsync, Rsnapshot, SMB/CIFS
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, Micro-ATX Gehäuse, 8Gb Ram, 64Gb M.2 SSD als Systemplatte, 64 GB SSD für Cache, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, bitwardenrs/server, linuxserver/mariadb, phpmyadmin/phpmyadmin, duplicati/duplicati
    Website: https://knilix.home.blog
  • Neu

    Re,

    ich habe mit meiner Fritze (7490) auch am internen Switch keine Probleme ... man muss aber vorher die Ports aus dem "Green" Status (=100MBit/s) in den Powermodus umkonfigurieren.

    Die Geschwindigkeiten bei den Powerlines werden genauso angegeben, wie bei WiFi - Bruttodatenraten. Für das Netto darf man bei Beiden getrost die Hälfte davon abziehen.
    Und auch Powerline reagiert empfindlich auf Störer - andere hochfrequente "Einstrahlungen" auf das Stromnetz gibt es u.A. durch Billignetzteile (z.B. Steckernetzteile) aus Fernost haufenweise.

    Sc0rp