Probleme mit Sata Controller, kein Bild und keine Verbindung

  • OMV5

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Probleme mit Sata Controller, kein Bild und keine Verbindung

    Hi bin jetzt seit einigen Tagen dabei unseren Homeserver komplett neu aufzubauen.
    Zum Einsatz kommt hier ein Gigabyte GA-990FXA Mainboard, als Prozessor ein amd fx 6350 und 8 gb ram.(Lag bei mir noch rum. Deshalb erstmal kein Neukauf:) Dazu zwei sata controller von ubit mit jeweils 8 ports. Als OS natürlich OMV. Habe das ganze jetzt mal Installiert und mich auch schon durch die Weboberfläche geklickt- Das alles jedoch ohne die Sata-Controller angeschlossen zu haben. Die Systemplatte hängt an einem der Onbord-Slots.
    Nun habe ich zwei Probleme:
    1. das ich wenn ich beide Controller angesteckt habe kein Bild mehr bekomme. Das ist mir aufgefallen als ich mich mit ihm an der Weboberläche anmelden wollte.
    Hier konnte ich mich nicht verbinden.
    Schnell ein Bildschirm eingesteckt und .... nix war. Kein Bild.
    2. Problem: Stecke ich jedoch einen Controller aus habe ich ein Bild. Jedoch steht jetzt beim Anmelden direkt am server "No network interface(s) available". Habe schon im Internet nach diesen Problem geschaut mit dem Verbindungsproblem. Raus kam das eventuell die kart als Netzwerkkarte erkannt wird..
    Wie gesagt einzeln eingesteckt sehe ich die am Controller angeschlossenen Festplatten im Bootloader. Jedoch bekomme ich von außen keine Verbindung auf den Server.
    Die karten hab ich auch mal an einem anderen Rechner eingebaut. Leider scheinen sie auch hier Probleme zu machen. Bild ist zwar da aber oben links in der Ecke blink ein weiser kleiner Balken als ob irgendwas laden würde.
    Bin jetzt am überlegen ob ich das ganze nochmal neu aufsetzen soll.
    Kann es sein das ich noch etwas am Board einstellen muss?
    Bin leider sehr unwissend und ziemlich gefrustet mittlerweile und hoffe das ihr mir irgendwas mit auf den Weg geben könnt das der Haufen hier endlich mal läuft..

    Mfg

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Logik ()

  • das mit der Netzwerkkarte ist ein bekannstes Problem. Neuerdings wird die Netzwerkkarte durch die PCI Adresse/Slot/... identifiziert. Durch die SATA Karten verschiebt sich diese Infos und die Netzwerkkarte hat einen anderen Namen. Schau dir den Thread an:

    No network interface(s) available nach SATA Karten einbau

    sollte dein Problem lösbar machen...
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • versuch mal nur eine Controllerkarte, also Stück für Stück an das Problem heranarbeiten. Da hast du ja ein Bild. Dann kannst du ja mal die Netzwerkkarte korrigieren, ob sie dann noch funktioniert.
    wenn du dann am System bist, kannst du ja mal mit lspci -vv alles anzeigen (bitte als Text hier mittels putty)

    und brauchst du wirklich 20 SATA Ports (6+8+8)? was für einen Server willst du da betreiben?
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Hallo, gute Idee. Gestern kam ich leider nicht mehr dazu es zu testen. Werde verscuhen mich da heute abend mal ranzusetzen:)

    Nein brauchen tu ich das definitiv nicht. Habe aber von einem Freund von einer Firmenauflösung ein Haufen noch sehr gut erhaltene WD Black 2tb bekommen.
    Unser alter Server platzt momentan aus allen näten und enfach nur weitere Platten ranhängen wollte ich nicht.
    Hab mir jetzt 2mm dicke Aluminium Platten anfertigen lassen für ein art "Gehäuse"...(vlt folgen ja noch Bilder wenn er fertig ist).

    Insegsammt werden wohl um die 40tb an Speicher verfügbar sein.
    Klar eigentlich viel zu viel ;) Wobei sich das um ca 1/3 dann noch veringert.

    Ist das erste mal das ich was mit omv mache, deshab die fragerei ;)
  • Kein Problem, auch ich lerne immer mit den Fragen der anderen Leute. Und schon öfters haben die von mir hier gefundenen Lösungen später selber geholgen...
    also nur her mit deinen Fragen.

    ad 40TB mit 20 Platten: willst du da dann ein RAID verwenden, sind die Daten eher statisch or sehr dynamisch? je nachdem gibt es andere Lösungen...
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Das freut mich zu hören;)

    Ca 12 tb lass ich in einem raid 10 laufen. den Rest als raid 0. Größtenteils sind es Filme und Musik. Meiner Meinung nach nicht sooo wichtig um gespiegelt zu werden. Urlaubsbilder, Dokumente und so kommen dann in den raid 10 verbund.
    Wie gesagt hatte es bis jetzt immer nur als Datengrab, je mehr ich aber über omv lese desto mehr merke ich was ich eigentlich noch aus dem Ding rausholen könnte. Naja mal schauen. Ich versuch jetzt erstmal die Karten zum laufen zu bringen...Und dann schau ich weiter :)
  • Re,

    RAID1 und auch RAID10 (mit Abstrichen) sind eig. keine "guten" RAID-Level, weil Sie keine Integrität gewährleisten, sondern rein einen Hardware-Ausfall abfedern ... btw. RAID1 ist Spiegelung, RAID0 ist "zusammenbinden" - d.h. dein RAID10-Verbund bestünde aus 2x3 Platten, mit einer Reinkapazität von 6TB, dein RAID1-Verbund hätte eine Reinkapazität von 2TB?
    Das halt ich für suboptimal ...

    Sc0rp
  • Also ich dachte an einen Raid-10(mirroring - striping) Verbund mit 6x2TB Festplatten. Also einer reinen Kapazität von 6tb.
    Und an ein Raid-0 Level, bestehend aus 14x2 TB Platten mit einer Kapazität von 28 tb.

    (Hätte lieber weniger Platten mit jeweils mehr kapzität, "aber nem geschenkten Gaul schaut man nicht ins Maul")

    Was würdest du mir empfehlen, wie ich mit so einer Konstellation umgehen soll, abgesehen von verkaufen;)?!
  • Re,

    verkaufen würde ich die 2TB Blacks nicht, finanziell bringt das nur Aufwand aber eig. keinen "Gewinn" gegenüber den Stromkosten oder anderem.

    Ich würde dir für die "Daten" ein RAID6 oder alternativ eine ZFS-Z2 empfehlen, und für den Medien-Archiv-Teil ein SnapRAID/mergerfs-Verbund mit 2 Parity-Platten nehmen ...

    Wenn du ein gutes Backup-Konzept für deine Daten hast, könntest du auch auf R5 oder ZFS-Z1 gehen, je nachdem wie lange du im Fehlerfall auf deine Daten verzichten könntest ... Backup ist dennoch Pflicht (ggf. ein/zwei HDDs aus dem Verbund nehmen und beiseite legen = Backup-Platten und Cold-Standby)

    Sc0rp
  • Re,

    ZFS ist eine ganz eigene Klasse, es gibt nix Vergleichbares ... und Es ist heftigst komplex!
    Es wartet aber auf der anderen Seite auch mit modernsten Features auf, die durchaus sinnvoll bei "großen" Verbünden sind ...

    Über ZFS habe ich im Forum auch schon viel geschrieben ... ;)

    Ansonsten RAID6 nehmen - auch wenn es alt ist, erfüllt es immer noch die Verbund-Aufgabe hervorragend, kümmert sich um Integrität, erhöht die Gesamtleistung, skaliert ganz gut und ist sehr gut dokumentiert ...

    Sc0rp
  • 20 Festplatten á 2 TB ? Das ist ja heftig.

    Ich hab 7 Platten á 10 TB und nutze MergerFS (UnionFS) und SnapRaid. Das hätte auch für Dich Vorteile :

    Bei 2 Paritätsfestplatten könnten 2 Festplatten ausfallen ohne Datenverlust.

    Bei Wiedergabe eines Filmes würde nur die Platte laufen auf der der Film ist und nicht alle. Bei Ausfall mehrerer Platten kann man die Platten die OK sind noch lesen.

    Nachteil : Es ist langsamer, aber für Filme ist das ja eh egal.

    Mein OMV kann 100 MByte/s lesen und 22 Mbyte/s schreiben. Für die größten 4K Filme bräuchte ich 13 MByte/s lesen.

    Grüße Bernd
  • Sc0rp schrieb:


    Ich würde dir für die "Daten" ein RAID6 oder alternativ eine ZFS-Z2 empfehlen, und für den Medien-Archiv-Teil ein SnapRAID/mergerfs-Verbund mit 2 Parity-Platten nehmen ...
    Bei 14 Platten würde ich schon eher 3 Parity Platten bei SnapRAID empfehlen, da die Platten auch schon etwas älter sind. Laut SnapRAID FAQ sollten zwar 2 reichen, aber je nachdem...
    Würden dir dann immer noch 22TB netto bleiben.
    Ambesten du liest dir mal den kompletten FAQ durch.
    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, 3*8TB+6TB SnapRaid (8TB Parity,3+3+2TB Parity2), FSP Aurum S 400W, Fractal Node 804
  • Danke schon mal für die ganzen Tipps.

    BerndFfm schrieb:

    20 Festplatten á 2 TB ? Das ist ja heftig.
    Ja 20 Platten sind heftig. Habe aber noch paar mehr hier liegen. ;)

    Habe jetzt mal das System neu aufgesetzt(Hatte eh die Falsche Platte bei der 1. Installatoin erwischt) und dabei eine Karte eingesteckt gehabt. Die Names vergabe hat anscheinen geklappt, die Platten werden erkannt.

    Das Problem jetzt ist das ich mich direkt am Server nicht anmelden kann. Er schluckt mein Login nicht. Die Namesvergabe für die andere Karte kann ich ja auch via putty machen?