Netzwerkfehler

  • Allgemein

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Netzwerkfehler

    Hallo Leute,


    ich bin neu hier und habe auch gleich ein Problem.


    Ich habe nun OMV zuerst auf einen Rasp betrieben dort fuktionierte alles
    wunderbar. Nun habe ich einen alten HP rechner genommen und dort OMV 5
    Drauf instaliert. Folgendes Problem, ich denke die Netzwerkeinstellungen
    sind nicht korrekt ich habe schon mehrere einstellungen versucht aber
    nichts hilft. Aktuell sind die Netzwerk einstellungen auf DHCP
    eingestellt. Zum Problem, ich kann den Rechner von intern und extern
    erreichen. Samba funktioniet so bedingt gerade. Die OMV-Extras bekomme
    ich nicht instaliert und ein apt-get update geht leider auch nicht er
    sagt er kann den Spiegelserver nicht ereichen. Könnt ihr mir helfen ?
  • Ja. OMV Web-Oberfläche öffnen, Links der Reiter "Netzwerk" wählen, dann auf "Schnittstellen" und die Netzwerkkarte, die dort drin steht Doppelklicken. Dann bis ganz runter scrollen und bei DNS-Server die 8.8.8.8 oder, wenn du eine aktuelle FritzBox hast, die IP-Adresse der FritzBox. Das wars eigentlich schon.

    LG Berti
    BS: OMV5 auf Buster
    SW: UFS, Snapraid, LEMP, rsync, Rsnapshot, SMB/CIFS
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, Micro-ATX Gehäuse, 8Gb Ram, 64Gb M.2 SSD als Systemplatte, 64 GB SSD für Cache, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, bitwardenrs/server, linuxserver/mariadb, phpmyadmin/phpmyadmin, duplicati/duplicati
    Website: https://knilix.home.blog
  • Re,

    Zonik schrieb:

    Zum Problem, ich kann den Rechner von intern und extern erreichen.
    @Berti: kein DNS-Problem ;)

    Zonik schrieb:

    Die OMV-Extras bekomme ich nicht instaliert
    Wie machst du das genau?

    Zonik schrieb:

    und ein apt-get update geht leider auch nicht er sagt er kann den Spiegelserver nicht ereichen.
    Darum kümmern wir uns später ...

    Also:
    - bist du der Konsole mächtig? (ich gehe wegen de RaspPi-Geschichte davon aus ...)
    - wie gut kennst du dich mit Linux aus?

    Sc0rp
  • Re,

    na dann ... prüfe zuerst, ob dein DNS "richtig" funktioniert:
    ping www.heise.de (oder jede andere Webadresse - am Besten aber Eine, die du "bisher" noch nicht angesurft hast, damit der Eintrag nicht aus dem Cache deines Routers geladen wird)

    Danach kannst du nochmal die Netzwerkkonfig checken:
    ifconfig oder ip a

    Und dann einfach mal die Spiegelserver durchpingen ...

    Sc0rp
  • Hi Sc0rp,

    beim Ping kommt:
    ping: heise.de: Temporärer Fehler bei der Namensauflösung

    bei Ip a kommt:
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether a0:d3:c1:23:6e:d5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.119/24 brd 192.168.2.255 scope global dynamic enp2s0
    valid_lft 1542068sec preferred_lft 1542068sec

    Das ist dabei heraus gekommen. Ping habe ich auch beim Spiegelserver gemacht kommt das gleich ebenso wenn ich andere anpingen möchte.
  • Re,

    also doch DNS-Probleme ... dann schau doch mal bitte was in der resolv.conf steht:
    cat /etc/resolv.conf

    Editieren kannst diese Datei mit:
    nano /etc/resolv.conf (und dort dann einfach "8.8.8.8" eintragen)

    Allerdings sollte der DNS-Server via DHCP-Antwort mitkommen ... läuft bei dir kein DHCP?

    Sc0rp
  • Re,

    dann hast du ein Router-Problem ... ein Ping (oder traceroute) sollte immer eine korrekte Namensauflösung bringen (Webadresse -> IP-Adresse).

    Ist DHCP auch am Router eingeschalten?

    Ich weiß jetzt nicht, ob auf dem Debian ein "dhclient" drauf ist, oder ein anderer DHCP-Client, aber versuch doch mal
    dhclient enp2s0

    ggf. musst du vorher noch "Reste entfernen" und z.B. die resolv.conf leeren ...

    Sc0rp
  • Re,

    also beim Router ist auch DHCP eingeschaltet, es ist ein Telekom Speedport.

    bei dem ausführen des Befehls kommt

    RTNETLINK answers: File exists

    reste habe ich aus der resolv.conf entfernt.

    Edit:
    Der Ping google.de läuft jetzt.

    So weiteres Problem nun. Wenn ich apt-get Update mache sagt er er kann den Spielserver nicht auflösen.
    Wenn ich OMV-Extras installieren möchte eben so er findet die dateien in Buster nicht .

    Apt-get update kommt folgendes:
    Ign:1 deb.debian.org/debian wheezy InRelease
    Fehl:2 deb.debian.org/debian wheezy Release
    404 Not Found [IP: 151.101.112.204 80]
    Paketlisten werden gelesen... Fertig
    E: Das Depot »deb.debian.org/debian wheezy Release« enthält keine Release-Datei.
    N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
    N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Zonik ()

  • Re,

    du hast also die Repo-Dateien verändert und anscheinend noch andere Dinge und wunderst dich warum nix funktioniert?

    Ich würde Dir empfehlen, OMV nochmal komplett neu aufzusetzen - wenn du spielen möchtest, am Besten in einer VM (VBox z.B).

    Wenn dein Netzwerk richtig funktioniert, dann sollte es mit einer Neuinstallation Problemlos klappen - inkl. Updates und Extras (bitte die Extras der 5er nehmen!).

    Sc0rp
  • Kleiner Tip. Setz` Dein System Neu auf, richte alles ein, mache dann ein CloneZilla-Backup deines Systems und bastle dann daran herum. Wenn dann was schief geht, einfach das Backup mit CloneZilla wieder herstellen und du sparst Dir die Neuinstallation. Auf dem Raspi gibt es auch verschiedene Backupmöglichkeiten, um die SD-Card oder die SSD zu Sichern.

    LG Berti
    BS: OMV5 auf Buster
    SW: UFS, Snapraid, LEMP, rsync, Rsnapshot, SMB/CIFS
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, Micro-ATX Gehäuse, 8Gb Ram, 64Gb M.2 SSD als Systemplatte, 64 GB SSD für Cache, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, bitwardenrs/server, linuxserver/mariadb, phpmyadmin/phpmyadmin, duplicati/duplicati
    Website: https://knilix.home.blog