mysql dump

  • OMV4

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hi. Ich sichere meine Datenbanken per Geplante Aufgabe, täglich mit folgendem Befehl. Jede Datenbank einzeln, inkl. mysql.


    Quellcode

    1. mysqldump -u root -pPASSWORT nextclouddocker | gzip > /sharedfolders/Backup-Database/`date +\%Y-\%m-\%d-\%H+\%M+\%S`-nextclouddocker.sql.gz

    Somit legt er täglich ein Backup mit Uhrzeit und Datenbankname ab. Bis 02. August hat auch alles reibungslos funktioniert. Siehe Bild.




    Seit 03. August tritt das Phänomen ein, dass die Dateigröße nicht mehr passt und die Daten auch nicht mehr wiederhergestellt werden können. Am System habe ich schon seit Ewigkeiten nichts mehr geändert, außer täglich apt-get update -y && apt-get upgrade -y.



    Bin durch Zufall darauf gestoßen. Ich habe jetzt alle Daten vorerst im mywebsql händisch exportiert. Hier funktionierte zum Glück auch das Importieren auf einem Testsystem. Aber wo könnte hier der Fehler sein? Gab es vielleicht eine Änderung, die an mir vorbei ging?

    LG Berti
    Bilder
    • 2.gif

      48,42 kB, 685×694, 1 mal angesehen
    BS: OMV4 auf Debian Stretch
    SW: UnionFilesystem mfs, Snapraid, LEMP-Stack, rsync, Rsnapshot, Duplicati, SMB/CIFS, Fail2ban
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, IN WIN 301C Micro-ATX Gehäuse, 2x 4Gb Ram, be quiiet! Straight Power 10, Transcend 64Gb M.2 SSD als Cache, 64 GB SSD für System, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, 3x wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, mprasil/bitwarden

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berti ()

  • Fehler gefunden...

    Folgende Einträge in der /etc/mysql/conf.d/mysqldump.cnf löschen.

    innodb_file_format = Barracuda
    innodb_file_per_table = 1
    innodb_large_prefix = 1


    Anschließend noch Dienst neu starten mit

    Quellcode

    1. service mysql restart


    Jetzt funktionieren auch die Befehle wieder wie gewohnt.


    LG Berti
    BS: OMV4 auf Debian Stretch
    SW: UnionFilesystem mfs, Snapraid, LEMP-Stack, rsync, Rsnapshot, Duplicati, SMB/CIFS, Fail2ban
    HW: MSI B350M MORTAR, Athlon 200GE, MSI Core Frozr L -Lüfter, IN WIN 301C Micro-ATX Gehäuse, 2x 4Gb Ram, be quiiet! Straight Power 10, Transcend 64Gb M.2 SSD als Cache, 64 GB SSD für System, 3x 4TB WD Red
    Docker: emby/embyserver, linuxserver/nextcloud, 3x wordpress, linuxserver/calibre-web, linuxserver/heimdall, vimagick/glances, v2tec/watchtower, mprasil/bitwarden