Update von OMV 3 auf 4 ...Updates??

  • OMV4

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Update von OMV 3 auf 4 ...Updates??

    ..bewahrheitet,

    ich wollte eigentlich nicht, habe mich dann aber doch getraut.

    Alle Plugins (OMV Extras, Autoshutdown und 2 andere...) deinstalliert und dann in der Konsole die Befehle gesetzt:

    Folge:


    Ich habe dann gegoogelt und das was ich, teils in Englisch, lesen konnte, in die Konsole eingegeben. Ich habe keine Einträge in "/etc/apt/sources.list" um den Eintrag "deb deb.debian.org/debian jessie-updates main" zu entfernen und alle Versuche, diese liste neu anzulegen übersteigt mein Gehirnschmalz. Ich habe es nicht geschafft.


    Ich kann über WEB gui noch auf den NAS zugreifen und wollte den Urzustand wiederherstellen, aber OMV Extras 3 lassen sich nicht neu installieren, auch diese Liste der Erweiterungen ist leer! Ich habe versucht in der Konsole OMV Extras downzuloaden, das funktioniert aber die Installation schlägt fehl!
    Da ich mit 2 Tastaturen arbeite, kann ich auch nichts aus OMV kopieren, deswegen die Bilder.
    DANKE für Eure Tipps!
    Gruß skinny
  • Hallo Sc0rp,
    ich habe, nachdem ich mich etwas beruhigt habe, was für mich verständliches gesucht und Dein Befehl (dieses mal über Putty) eingegeben.


    Ich habe dann mit "Strg+O" gespeichert und mit "Strg+X" beendet, "apt-get update" gestartet und dann das Update auf OMV nochmals angestoßen, irgendetwas fehlt ...
    Gruß skinny
  • Danke Sc0rp :thumbup: , ich habe den Befehl eingegeben und das wurde angezeigt:



    Danach ist das Update Gottseidank durchgelaufen, ich kann mich auf die WebGUI einloggen aber ich kann nichts ändern, manchmal ist alles leer und ich muss mich neu anmelden, damit ich wieder was angezeigt bekomme.
    Wenn ich speichern möchte geht zwar ein Feld auf aber das ist leer und zeigt nicht an ob ich die Änderung übernehmen möchte!
    OMV Extras habe ich dann über die Konsole installiert, weil es über das WEB Interface nicht funktioniert hat.
    Habe mehrmals neu gestartet und habe über firstaid den WebGui cache zurückgesetzt, keine Änderung. ?(

    Gruß skinny
  • Hallo,
    mein OMV 4 läuft aber er sendet mir jede Nacht Update Nachrichten, 2x die gleichen.
    Letzter Satz ist immer"Download complete and in download only mode"

    Die Nachrichten sind an verschieden Tagen zwar unterschiedlich, aber diese Zeile "The following NEW packages will be installed: linux-image-4.19.0-0.bpo.5-amd64" ist immer enthalten, warum?
    Wenn er es einmal installiert hat warum dann jede Woche ein neuer Download?

    Letzte 2 Nächte um 00:30 & 04:30 immer diese Nachricht:

    CRON-APT RUN [/etc/cron-apt/config]: Tue Sep 10 04:00:01 CEST 2019 CRON-APT SLEEP: 862, Tue Sep 10 04:14:24 CEST 2019 CRON-APT ACTION: 3-download CRON-APT LINE: /usr/bin/apt-get -o Acquire::http::Dl-Limit=25 dist-upgrade -d -y -o APT::Get::Show-Upgraded=true Reading package lists...

    Building dependency tree...

    Reading state information...

    Calculating upgrade...

    The following NEW packages will be installed:

    linux-image-4.19.0-0.bpo.5-amd64

    The following packages will be upgraded:

    base-files gettext-base grub-common grub-pc grub-pc-bin grub2-common

    libcups2 libgd3 libglib2.0-0 libicu57 libldap-2.4-2 libldap-common

    libnghttp2-14 libsystemd0 libudev1 libxslt1.1 linux-image-amd64

    openmediavault-omvextrasorg openssh-client openssh-server

    openssh-sftp-server systemd systemd-sysv udev usbutils

    25 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

    Need to get 0 B/68.5 MB of archives.

    After this operation, 267 MB of additional disk space will be used.

    Download complete and in download only mode

    Vor 4 Tagen war noch diese Zeile dabei "Get:1 ftp.de.debian.org/debian stretch/main amd64 base-files amd64 9.9+deb9u11 [67.5 kB] Fetched 67.5 kB in 2s(25.1 kB/s) Download complete and in download only mode"

    Ist das OK so oder sollte ich da händisch eingreifen?

    Danke!
    Gruß skinny
  • Re,

    apt-get update && apt-get upgrade && apt-get dist-upgrade && apt-get autoremove
    ... wäre die komplette Zeile - wenn man dann noch die Zwischenfragen ("darf installieren (Y/N)") gleich mit beantworten möchte:
    apt-get update && apt-get -y upgrade && apt-get -y dist-upgrade && apt-get -y autoremove

    Siehe manpages.debian.org/stretch/apt/apt-get.8.de.html

    Sc0rp