Docker - Konflikt mit br0

  • Hallo zusammen,


    Ich bin hier neu und suche nach Hilfe zu meinem Problem.


    OS = ARMBIAN 5.75 stable Debian GNU/Linux 9 (stretch) 4.4.174-rk3399
    OMV = 4.1.20-1


    nun zum Problem:
    Ich brauche JDownloader da er aber nicht mehr in OMV4 als addon funktioniert bin ich gezwungen Docker CE zu benutzen.
    Docker addon erstellt automatisch docker0 Brücke danach funktioniert meine br0 nicht komplett nur halbwegs, das heißt eth0 bekommt Verbindung mit Internet aber eth1 nicht .
    Dazu kleine Erklärung - eth1 funktionierte bis jetzt als ein Switch da bekommt weiterer PC Internet.


    Meine Netzwerkkonfiguration läuft nicht mehr über /etc/network/interfaces sondern über den tool namens nmtui (network-manager) laut diese Beschreibung ganz unten.
    Wie gesagt br0 funktioniert gut aber sobald Docker installiert wird besteht dieses Phänomen.


    Ich hoffe auf Eure Hilfe :)

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]
    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]
    [ Nextcloud 18.0.4 @ ODROID C2 ]
    [ Motioneye @ RPi4]

    Einmal editiert, zuletzt von Aux ()

  • Ich habe eine Lösung des Problems hier gefunden.


    In /etc/network/interfaces habe ich post-up iptables -F FORWARD && iptables -P FORWARD ACCEPT eingetragen, da die Einträge in /etc/network/interfaces von network-manager respektiert werden, zudem in  /etc/sysctl.conf die Zeile net.ipv4.ip_forward=1 unkommentiert hatte, funktioniert alles nun wie es soll auch nach dem neustart. :)

    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]
    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]
    [ Nextcloud 18.0.4 @ ODROID C2 ]
    [ Motioneye @ RPi4]

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!