Bonding / Bündelung von Netzwerkkarten

  • Hi,
    hat schon mal jemand erfolgreich unter OMV 2 Nic's zusammengefügt?
    In der Weboberfläche ist das bescheiden, zu Fuß (/etc/network/interfaces) sollte es eigentlich funktionieren.
    Eigentlich :-)
    Hier im Bespiel der Einfachheit halber per dhcp, aber auch Statisch nix :(


    Trotz eth0 und eth1 manuell ziehen die sich immer eine IP vom Dhcp.
    Beide bekommen einen Link, im Switch ist alles richtig eingestellt.
    Vermutung: OMV bastelt da irgendwas rüber? Ich bin mir nicht sicher, in der Weboberfläche
    werden Eth0 und 1 als deaktiviert angezeigt. bond0 exisiert dann zwar, kann aber nicht als Master ausgewählt werden.
    Hints?


    Gruß Stephan

  • ich glaube, du solltest die beiden Interfaces eth0 und eth1 nicht definieren, da sie keine unabhängigen Interfaces sind.
    siehe auch Bonding.
    versuch also mal eht0 und eth1 auszukommentieren.

    SW: OMV 4.1.35 (Arrakis), Snapraid mit mergerfs, Minidlna
    MSI B150M ECO, Intel Pentium G4400, 16GB Kingston DDR4, SSD 250GB, 4TB Daten, SnapRAID: 4*8TB (Seagate Archive)+6TB, 2*8TB Parity (WD White), FSP Aurum S 400W, Fractal Node 804

  • Re,


    genau, erst Mal prüfen (Schritt für Schritt) ob alle Voraussetzungen erfüllt sind:
    dpkg -l | grep ifenslave (zeigt ob die nötige Software vorhanden ist)
    cat /etc/modules | grep bonding (zeigt, ob das benötigte Modul beim Start geladen wird)


    Und dann natürlich die Frage, was du mit dem Bonding erreichen möchtest - und welche Services du über den Bond verfügbar machen möchtest.


    Sc0rp

  • Hi,
    im Prinzip erst mal nur aus Spieltrieb um zu wissen das es prinzipiell funktioniert. Schön zu wissen wenn ich ein Patchkabel ziehe dass die Verbindung trotzdem weiter funktioniert.
    Das Modul bonding ist geladen; die benötigte Software ebenfalls installiert. Aktuell habe ich das Projekt aber erst mal wieder hintenan geschoben.
    Wobei ich mich schon über die gesteigerte Bandbreite freuen würde.
    Da Basteleien am Lan ja immer das aussperren beinhalten muss ich erst mal Zeit abwarten wo niemand da ist.
    Mein NAS ist ist ein Terramaster F2-420; funktioniert soweit ganz gut nur für den Vga-Adapter muß ich das Gehäuse öffnen.
    (Radius für meine Wlan-Anmeldung läuft auf dem Terramaster, das Kindergeschrei weil kein Wlan funktioniert ist ziemlich laut :-) )
    Gruß Stephan

  • Re,

    Wobei ich mich schon über die gesteigerte Bandbreite freuen würde.

    Naja, freue dich da nicht zu früh ... CIFS skaliert bis Samba v3 nicht richtig mit und die meisten Bonding-Modes funktionieren nur im Multi-User-Umfeld richtig ... ich hatte schon 4x1GBit-Bonds und war recht entäuscht :P (NFS skaliert hingegen ordentlich!)


    Einzig und alleine die Redundanz (Fail-Over) wäre nutzbar, aber in einem Kupferbasierten Home-LAN unwahrscheinlich und sicher kurzfristig reparierbar :D


    Sc0rp

  • Re,

    Naja, freue dich da nicht zu früh ... CIFS skaliert bis Samba v3 nicht richtig mit und die meisten Bonding-Modes funktionieren nur im Multi-User-Umfeld richtig ... ich hatte schon 4x1GBit-Bonds und war recht entäuscht :P (NFS skaliert hingegen ordentlich!)
    Einzig und alleine die Redundanz (Fail-Over) wäre nutzbar, aber in einem Kupferbasierten Home-LAN unwahrscheinlich und sicher kurzfristig reparierbar :D


    Sc0rp

    Oh, enttäuschend wegen dem nicht wirklich zu erwartenden Vorteil. WIe gesagt, aktuell eher aus Spieltrieb.
    "Schön zu wissen das es usw...."
    Kupfer, zu Hause? Oha :-) Wenn ich da an meinem LWL-Link vom Router zu Switch denke :-)
    ^ ne, hast ja Recht.
    Gruß Stephan

  • Re,

    Wenn ich da an meinem LWL-Link vom Router zu Switch denke

    Welcher (Heimnetz-) Router hat denn einen Glasport? (den Einzigen, den ich kenne, ist der Clearfog Pro).
    POF oder GF? Bandbreite? Welche SFP's?


    Bei mir haben nur die Switche Glasports (und die werden auch genutzt, 1x LX und 1x SX, 50/125er MM) ... und wenn ich möchte auch meine Server (Karten liegen im Schrank, bringen bei mir zH ja nix beim Bonding :( ).


    Sc0rp

  • Re,

    Bei mir haben nur die Switche Glasports (und die werden auch genutzt, 1x LX und 1x SX, 50/125er MM) ... und wenn ich möchte auch meine Server (Karten liegen im Schrank, bringen bei mir zH ja nix beim Bonding :( ).


    Sc0rp

    Router ist ein Mikrotik rb2011* mit einem zusätzliche SFP-Port. SFP Modul ist von Cisco, der Router sagt FTLF8519P3BNL

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!