Kein Zugriff per Browser / FileZilla aus dem Internet möglich

  • Ich habe auf einem Raspberry Pi ein Open Media Vault aufgespielt und mich an diese Anleitung gehalten:http://www.technikaffe.de/anle…iavault_inkl._wake_on_lan


    Als Router nutze ich einen neuen AMV [definition=42,0]Fritzbox[/definition] 7490
    Über meinen [definition=40,0]Windows[/definition] PC kann ich über „Netzlaufwerk verbinden“ problemlos auf die Festplatten zugreifen und auch Dateien aufspielen und runter laden.
    Soweit funktioniert nun alles. Doch jetzt kommt das ABER.
    Aber … ich komme nicht über das Internet auf die Festplatten und weis nicht mehr was ich noch falsch machen könnte so viel habe ich schon probiert und nach Anleitungen im Netz rumgefummelt.


    1. Ich komme nicht mit einem Webbrowser auf meine Festplatten.
    2. Ich komme nicht mit FileZilla auf meine Festplatten.


    Ich habe dem Rasberry Pi mit Open Media Vault in der [definition=42,0]Fritzbox[/definition] eine feste IP zugewiesen. Auch das funktioniert seit Tagen problemlos.
    In der [definition=42,0]Fritzbox[/definition] habe ich unter „Portfreigaben“ mal die Ports 21-22, 443 und 80 geöffnet für „IPv4“ und „IPv6“.
    In der [definition=42,0]Fritzbox[/definition] habe ich DynDNS mit https://www.duckdns.org/eingerichtet.


    In der Anleitung bei Punkt 9: Benutzer … habe ich auch angelegt.
    „Freigabe in [definition=40,0]Windows[/definition] einbinden“ geht auch wunderbar wie oben ja schon geschrieben.



    Weiter komme ich nicht weiter. Klingt komisch aber so meine ich es.


    Ich kann nicht prüfen ob ich überhaupt zur [definition=42,0]Fritzbox[/definition] komme, geschweige denn dahinter auf den Raspberry Pi noch auf die Festplatten?



    Kann mir hier jemand bei dem Problem helfen und was braucht Ihr dafür von mir für Daten, Logs, Screenshoots?

  • Ich habe auf einem Raspberry Pi ein Open Media Vault aufgespielt und mich an diese Anleitung gehalten:technikaffe.de/anleitung-255-i…iavault_inkl._wake_on_lan

    Wake on Lan ist mit der Raspberry Pi nicht möglich!

  • für Filezilla brauchst du einen FTP Zugang im OMV Inkl Freigaben.

    Hardware: Asrock H97 Performance, Intel I3 4160, 2x G.Skill F3-1600C11S-8GNT (16gb Ram), be quiet Pure Power L8 300W, Thermalright LeGrande Macho,
    Nanoxia Deep Silence 5 Rev.b, Kingston SSDNow V300 2,5" SSD 120 GB, Western Digital Red 3x4tb,1x4tb HGST Deskstar Nas


    Software: Openmediavault 3.0.99 Erasmus, 4.9.0-0.bpo.6-amd64, Snapraid mit mergerfs Pool, Minidlna, Plex, MySql, ClaimAV, Powertop und Sonstiges

  • Servus! und Hallo.


    @Wolf2000 Das mit Wake on habe ich übersprungen. Da ich jetzt lese das es eh nicht geht lasse ich das dann auch später gleich sein. Ein Problem weniger ;)
    @Joogie ... Muss ich mich noch mal mit befassen.
    @Schattenwelt "Hast du auch die Masquerade Adresse eingetragen? Nutzt du passiv oder aktiv FTP?" Ich kann diese Fragen leider nicht beantworten da ich noch nicht das Wissen habe.


    .... Ich wollte die Nacht eigentlich noch Antworten aber habe mich dazu entschieden das Open Media Vault komplett neu auf dem Raspberry Pi aufzuseten.
    Alles noch mal Schritt für Schritt machen, lernen und Fehler die man macht erkennen.
    So kann ich gleich mal probieren was ich machen muss wenn mir der RaspberryPi mal abraucht und dann machen muss damit alles wieder funktioniert.
    Bei der Neuinstallation habe ich den Hinweis aus dem Beitrag: http://www.technikaffe.de/foru…inden/&postID=11289#post1@Joogie genutzt und die Platten ohne nicht am RaspberryPi gehabt.


    Erster Erfolg, ich kann nun mit dem Browser aus dem Internet (Auch mit Handy außerhalb des Netzwerk getestet) auf den Open Media Vault zugreifen. In der Adresszeile macht es doch einen Unterschied ob ich nun "http" oder "https" eingebe. Bei den ganzen Anleitungen, die mich sicherlich weiter gebracht haben, fehlen aber solche "einfachen" Erklärungen die es einen Absoluten Leuling auf einem Gebiet erst ermöglichen nachzuvollziehen was man da eigentlich macht. Ich stoße immer wieder auf Erklärungen wo man mitbekommt das der Autor davon aus geht das der Leser schon einiges an Basiswissen mitbringt wenn er sich mit dem Thema befasst.


    Ich bin nun einen Schritt weiter, juhu !
    Und jetzt kommt ein dickes ABER. Ich habe nun die Festplatten wieder an den Raspberry Pi mit Strom versorgt und auch den OpenMediaVault neu gestartet.
    Was nun passiert ist:


    Datenspeicher
    Datenspeicher - Reale Festplatten

    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk: /dev/mmcblk0
    Modell: N/V
    Seriennummer: N/V
    Hersteller: N/V
    Kapazität: 14,84 GiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk: /dev/sda
    Modell: Elemets 25A3
    Seriennummer: 574.....E
    Hersteller: WD
    Kapazität: 1,82 TiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------

    Laufwerk: /dev/sdb
    Modell: Elemets 25A3
    Seriennummer: 574.....9
    Hersteller: WD
    Kapazität: 1,82 TiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------



    Datenspeicher - Dateisysteme:
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk(e): /dev/mmcblk0p1
    Datenträger: boot
    Dateisystem: vfat
    Gesamt: 62.01 MiB
    Verfügbar: 36.72 MiB
    Verwendet: 25.29 MiB
    Eingebunden: ja
    Referenziert: nein
    Status: Online
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk(e): /dev/mmcblk0p2
    Datenträger:
    Dateisystem: ext4
    Gesamt: 3.52 GiB
    Verfügbar: 1.87
    Verwendet: 1.45 GiB
    Eingebunden: ja
    Referenziert: ja
    Status: Online
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------



    Datenspeicher - Dateisysteme:

    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    nichts eingetragen, nichts zu sehen
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------



    Unter Datenspeicher - Dateisysteme kann ich /dev/mmcblk0p1/ anwählen (rot markiert). Dann könnte ich sie "Aushängen" und "Löschen"
    Unter Datenspeicher - Dateisysteme kann ich /dev/mmcblk0p2/ anwählen (rot markiert). Dann nichts damit machen, Weder größe Verändern, Quota, Einbinden, Aushängen, Löschen ist markiert.


    Einfach neu installierten und Festplatten wieder dran stecken will bei mir nicht funktionieren.
    Ich habe Testdaten auf den Platten.


    LIebe Grüße ... die Regierung steht hinter mir und verlangt das ich jetzt einkaufen fahre ;)



  • Hi
    An der /dev/mmcblk0p1 und dev/mmcblk0p2 kannst du unter OMV nichts ändern das ist das System!
    Die /dev/mmcblk0p1 ist für das booten verantwortlich und die dev/mmcblk0p2 ist das Betriebssystem.
    Ich habe gesehen das du nicht die ganze SD-Karte nutzt das kann man aber mit raspi-config ändern.
    Um die Platten zu sehen musst du auf Reale Festplatten gehen wenn sie nicht da sind dann suchen.


    Ps: das war nicht die letzte Neu Installation! :D

  • Hallo ... MotoGP zuende, kann ich mich dem OMV Problem wieder zuwenden.


    @Wolf2000 Wie macht man das denn die ganze SD-Karte nutzbar zu machen? Ich dachte eigentlich das es eine lehre Karte ist. Was bringt eine voll nutzbare Karte?


    Die Platten sehe ich doch oder:


    Datenspeicher

    Datenspeicher - Reale Festplatten
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk: /dev/mmcblk0
    Modell: N/V
    Seriennummer: N/V
    Hersteller: N/V
    Kapazität: 14,84 GiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk: /dev/sda [i][i]<--------------------------- ?[/i][/i]
    Modell: Elemets 25A3
    Seriennummer: 574.....E
    Hersteller: WD
    Kapazität: 1,82 TiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------
    Laufwerk: /dev/sdb [i]<--------------------------- ?[/i]
    Modell: Elemets 25A3
    Seriennummer: 574.....9
    Hersteller: WD
    Kapazität: 1,82 TiB
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------


    Ich habe letzte Nacht noch viel im Netz gesucht, aber ich finde keine Lösung :(

  • Gib auch in putty:
    df -h
    Dann wirst du Sehen

    Die SD hat 14,84 GiB du hast nur mehr noch 1,57 Verfügbar!
    Ein paar Sachen installieren und sie ist voll und dann geht nichts mehr!

  • Das ist das img von OMV .


    Du kannst dir mein Tool installieren, aber mache vorher ein Kopie deiner SD-Karte:
    Mit dem Win32DiskImager Vorsicht nicht mit Write sondern mit Read du mustt aber vorher oben z.b.raspi.img eingeben.
    Mein Tool:

    Code
    git clone https://github.com/Wolf2000Pi/wolf2000-tools.git && cd wolf2000-tools && chmod +x install-wolf2000-tools.sh && ./install-wolf2000-tools.sh && cd



  • Ich habe mir mal einen abgebrochen bis ich verstanden habe was ich machen soll.
    Mit dem Tool komme ich noch nicht so klar.
    Ich habe die SD Karte noch mal in meinem Windowsrechner formatiert und dann das OMV-Image mit dem Win32 Disk Imager auf die SD Karte gespielt.


    ... Ist das bis hier hin richtig so?


    Nun habe ich die Karte in den RaspberryPi gesteckt, die USB Stecker der Festplatten dran gelassen aber die Stecker der Stromversorgung gezogen.
    RaspberryPi eingesschaltet.
    Putty gestartet und nun sieht das so aus:
    [Blockierte Grafik: https://abload.de/img/raspberrypiscreenshooyupim.jpg]

  • Guten Morgen!


    Ich habe mein OMV wieder hergestellt und die Testdaten sind noch auf dem Raid Mirror.
    Weiter komme ich aber wieder nicht. Ich kann zwar über das Netzwerk „Netzlaufwerk verbinden“ an meine Ordner aber bin zu doof das über das Internet zu machen.
    Das einzige was mir möglich ist an die Anmeldung zu gelangen. Die angelegten User können sich auch einloggen aber so komme ich ja nicht auf meine Ordner auf dem OMV.


    [Blockierte Grafik: https://abload.de/img/omv-004-loginizorf.jpg]


    Was muss ich machen das ich auf die Daten zugreifen kann?

  • Ich habe letzte Nacht viel rumprobiert und das Netz nach gehaltvollen Informationen durchforstet.
    Eine DAU Anleitung gibt es leider nicht, nur Forenbeiträge wo Vorwissen schon vorhanden ist und mit Abkürzungen rumgeschmissen wird *error*


    Ich bin nun soweit das ich folgende Meldung im FileZilla bekomme:


    Status: Auflösen der IP-Adresse für xxxxxx.duckdns.org
    Status: Verbinde mit [xxxx:xx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx]:xx...
    Status: Verbindung hergestellt, warte auf Willkommensnachricht...
    Status: Initialisiere TLS...
    Status: Überprüfe Zertifikat...
    Status: TLS-Verbindung hergestellt.
    Befehl: USER Nico
    Antwort: 331 Password required for Nico.
    Befehl: PASS *****************
    Antwort: 530 Login incorrect.


    Ich habe es auch annonym probiert ... Ich bekomme einfach keinen Zugriff.
    Kann ja nur noch eine Kleinigkeit sein ... nur welche ?!?


    Jetzt ess ich erst mal Frühstück und schau das DTM Rennen vom Samstag und setze mich dann noch mal ran.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!