Proxmox

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • so habe jetzt mal Proxmox installiert das OMV3 anscheinend das ZFS raid verloren hat.
    Jetzt habe ich nochmal OMV3 in einer VM erstellt. Nur wie reiche ich die 6 Festplatten durch die als Speicher zur Verfügung stehen sollen. auf der Weboberfläche finde ich nichts.
    Unter Disk werden sie in Proxmox angezeigt nur weis ich nicht wie ich die an die VM OMV3 weiterreiche.

    Danke für eure Hilfe

    Gruß Swen
  • meine CPU unterstützt alles

    wenn ich per console oder Winscp drin bin wird komischer weise die Partition mit den 6x4 TB platten zusammen gefasst angezeigt. und kann auch runter kopieren wenn ich per Winscp drauf bin auf dem Proxmox nur muss ich noch rausfinden wie ich das in die VM einbinden kann.

    Sie wird an gezeigt wenn ich als root eingeloggt bin als /hondasafe mit den einzelnen Ordnern drin.

    *ergänzung* ich hatte das damals in OMV 3 mit der der Erweiterung ZFS als raid angelegt. wie gesagt ich habe nur Proxmox installiert auf die SSD und wenn ich nun lokal oder putty/WinSCP drauf bin sehe ich den Raid verband als das Verzeichniss direkt als /HondaSafe/ mit den ganzen damaligen Unterordnern/Freigaben
    Wenn ich in Proxmox das einfügen will kann man dort nur als inhalte ISO oder Images angeben und er will soweit ich es verstanden habe dort einen neuen platz auf der gesamt Partition anlegen. Er zeigt mir auch bei der auswahl alle Platten als verbund an. also die ganzen 14,.. TB(inkl in benutzung/belegt ca 7,5TB) und nicht jede einzeln. nur in Disk werden sie einzeln dargestellt. Dort kann man aber nichts weiter machen ausser die Smart werte nachschauen bzw status abfragen.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von hondaracer ()

  • Re,

    ich habe keine Erfahrungen mit Proxmox, allerdings liest sich dein Post so, als würde Proxmox den ZFS-Verbund schon nativ erkennen und einbinden - da Proxmox ja ein Linux ist und KVM benutzt, wäre das auch mehr als wahrscheinlich.

    Du müsstest also nur noch der VM "OMV" den Ordner freigeben ...

    Sc0rp
  • leider habe ich es nicht hinbekommen den ZFS Verbund durchzureichen an das OMV system. also habe ich wieder OMV als host system drauf. Wobei ich sagen muss das sehr gut Funktioniert hat. Habe mal noch windows 10 und win 7 installiert und rumprobiert. Schade eigentlich hatte schon gut funktioniert. Aber wenn ich den Daten Verbund nicht durchreichen kann. Dann bringt mir das nichts. War zu doof wahrscheinlich dazu. Jedenfalls ist mein englisch zu schlecht dafür :(

    Swen
  • da ich schon ein ZFS verbund habe und da daten drauf sind. ( Proxmox kommt ja damit klar, mit dme Vorhandenen verbund)
    und proxmox soll ja nur als Grundsystem da sein und in einer VM soll OMV laufen. Und die platten laufen bei mir eh die ganze Zeit durch. Also ist das mit dem Spindown egal.

    Er findet ja den ZFS verband nur weis ich nicht wie ich ihn an eine VM durchreiche jedenfalls steige ich nicht durch wie ich es machen muss.
  • Re,

    hondaracer schrieb:

    Er findet ja den ZFS verband nur weis ich nicht wie ich ihn an eine VM durchreiche jedenfalls steige ich nicht durch wie ich es machen muss.
    das weiß ich auch nicht - m.W.n. gibt es keine Möglichkeit bei Virtualisierung "Dateisysteme" durchzureichen, entweder:

    Niemand schrieb:

    es gibt zwei Möglichkeiten:
    A) du reichst jede HDD einzeln durch
    B) du reichst den SATA controller komplett durch (dafür ist vt-d oder AMD-Vi/IOMMU notwendig), aber da muss die Platte mit Proxmox an einen anderen Controller
    C) du gibst eine Ordner für die OMV-VM frei ... das könnte z.B. in deinem Fall der Mountpoint deines ZFS-Verbundes sein (Einhängepunkt), unter VBox heißen die "gemeinsam genutzt Ordner" unter Proxmox weiß ich es nicht ...
    D) du konfigurierst NFS oder/und Samba auf dem Proxmox-Host und nutzt diese Netzwerkfreigaben dann in OMV (da muss man aber noch ordentlich Hand anlegen)

    E) du machst es richtig, und konfigurierst auf dem ZFS-Verbund einen virtuellen Datenträger für dein OMV (und verschiebst dann die Daten dorthin)

    Aus OMV-Sicht hast du aber nur die Möglichkeiten A) und B), da sonst OMV sein Datenträger-Konzept nicht verwirklichen kann ... oder eben das einzig Richtige: E).

    Ich verstehe immer noch nicht, wie man unbedingt eine NAS-Funktionalität virtualisieren möchte, und dann Probleme mit dem Virtualisierungs-Kozept hat ... wie ich schon oft geschrieben habe, ergibt es sorum überhaupt keinen Sinn (wenn man Aufwand und Nutzen betrachtet). Anders herum (auf einem NAS andere Maschinen zu virtualisieren) ergibt dagegen deutlich mehr Sinn ...

    Sc0rp
  • Habe ja schon VBox auf OMV 3 drauf gehabt und was soll ich sagen funktionieren ist anders.
    Aber ich probiere mal rum habe jetzt mal noch WIN10 installiert zum testen habe den ZFS verband jetzt nochmal platt gemacht. OMV3 läuft irgendwie nicht richtig.
    Jetzt Versuche ich mal rum habe ja alles noch auf Backupsystem. Sind ja nur knapp 7,5tb die ich wieder rüberschieben muss ^^
    Aber bevor ich das mache muss das alles richtig laufen.
  • Re,

    hondaracer schrieb:

    Habe ja schon VBox auf OMV 3 drauf gehabt und was soll ich sagen funktionieren ist anders.
    ???
    Ich benutze VBox schon seit Jahrzehnten (und zwar seit VMware seine Lizenzpolitik massiv änderte) und seither ohne jegliche Probleme ... wie gesagt, man sollte sich schon mit Virtualisierung im Allgemeinen und natürlich auch mit der jeweiligen Applikation auch ein wenig beschäftigen (grobe Hausnummer: man sollte es konfigurieren können). Auch das Konzept der verschiedenen Virtualisierungstechniken sollte man kennen (also nicht Alle, nur das, Welches man einsetzt - in deinem Fall mit Proxmox ist es KVM)

    Was hat denn genau mit VBox nicht funktioniert?

    Besonders der Weg virtuelle Maschinen auf einem Windows-Rechner aufzusetzen und dann auf einen Headless-Server umzuziehen schätze ich an VBox ... und kann das auch nur empfehlen.

    Sc0rp
  • Hatte mal VBOX unter OMV 3 Installiert aber die Mausnutzung im Windows was ich in die VM installiert hatte ging nicht zu richtig zu benutzen. jedenfalls konnte man nur mit konsole arbeiten und dazu hatte ich keine lust. Weil der Mauszeiger wild rumsprang bzw wenn ich drauf war um das remoute freizuschalten nur nach langen versuchen mal geschafft habe einen Button zu erwischen. Ob es jetzt besser ist kann ich nicht sagen aber bei mir war es so. Ich propiere jetzt noch ein bissl rum. Proxmox war ja nur eine Idee zum testen. Eigentlich wollte ich schon wieder OMV drauf haben. Aber irgendwie bekomme ich das nicht auf dem neuen Board richtig zum laufen. Immer irgendwelche probleme.
    Ziel war ja OMV 3 als Grundsystem und dann 1-2 VM´s zum testen bzw für noch einen Game server bereitzustellen. Auf OMV 2 mit dem alten Nas klappte es ja einwandfrei über VBOX nur was halt das alte nas etwas unterbewaffnet für den Gameserver. Solange nur 2 leute drauf waren ging das einwandfrei aber sobald halt noch 2 draufgekommen waren unspielbar fast.
    Mein neuer hat da ja schon bissl mehr dampf und müsste es schaffen.
    Ich schaue mir mal jetzt Win10 pro an und dann entscheide ich. Vielleicht ist ja doch was mit dem Board nicht in Ordnung. Auf jedenfall muss das mit der USV klappen das der PC runterfährt wenn stromausfall ist.
    Solange das nicht geht muss ich schauen. An der USV kann es nicht liegen da es ja am aleten Nas sowie an meinem Arbeits/Spielerechner ja einwandfrei geht.
    Vieleicht kann ja das Technickaffe team das mal mit Ihrem Board testen, ob USV die per USB angeschlossen sind dort unter OMV3 funktionieren, sollten Sie das Board noch haben. Die hatten ja das Board getestet.

    Gruß Swen