plex webinterface und server weg

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • plex webinterface und server weg

    Ich brauche mal dringend Hilfe weil mir der Ansatz fehlt.

    Gestern hat mich meine Plex Oberfläche darauf aufmerksam gemacht das es ein plex-update gibt.
    also habe ich die Aktualisierungsverwaltung von omv bemüht, die aber kein Update findet.
    Ich dachte das hatte ich schon mal im Bezug auf plex also habe ich wie damals das Update nach der Anleitung für ein manuelles Update unter "Plex Media Server --> Setup Info durchgeführt".

    Mit dem Resultat das jetzt das Webinterface von Plex und auch der Zugriff auf den Server via Android-App und Rasplex nicht mehr möglich sind.
    Der versuch Plex via Browser zu erreichen scheitert schlicht mit der Meldung "Verbindung fehlgeschlagen"
    Die Adroid-App meldet "Der Server ist nicht erreichbar"

    Bis ich begonnen habe diesen Text zu schreiben war außerdem die Virtualbox nicht erreichbar Sinn gemäß mit dem Fehler "konnte die Adresse 127.0.0.1port 18xxx nicht erreichen".
    Als ich gerade die Meldung provozieren wollte lief alles wieder wie gewohnt so das ich die genaue Meldung gerade nicht reproduzieren.

    Da das Update nach der Anleitung per dpkg installiert wurde habe ich versucht es mittels dpkg -r wieder zu löschen was leider ebenso scheiterte wie das entfernen und neu installieren über die omv oberfläche.

    ich bekomme Plex einfach nicht zum laufen und finde nicht den Ansatz um das Problem zu lösen, sehr zum Leidwesen meiner Tochter die ihre Serien via Plex schaut.

    In unregelmäßigen Abständen habe ich über "Sicherung --> Systemsicherung" Sicherungen erstellt mit dem Resultat das ich jetzt irgendwie nicht den Weg finde um die Sicherung wieder zurück zu spielen.

    So mit wäre ich für jede Hilfe dankbar.


    -------------------------------------------------
    Kleine Ergänzung:

    Ich habe mir das Update erneut heruntergeladen und nach Anleitung installiert.
    Leider auch diesmal kein Erfolg außer das meine Virtualbox Oberfläche diesmal noch da ist. (jedenfalls bis jetzt)

    Allerdings konnte ich einige Fehlermeldungen reproduzieren und auf diesem Wege der Lösung etwas näher kommen.
    Offensichtlich kann der Dienst nach dem Update nicht mehr gestartet werden weil die Startroutine auf einen Symlink in /etc/init.d verweist der "plexmediaserver" heist.
    Dieser Wiederum verlinkt auf /lib/init/upstart-job
    Bis /lib/init/ komme ich, dort finde ich aber nur ein paar Script-Dateien (.sh) aber nichts was "upstart-job" heist

    Kann mir bitte jemand sagen was hier falsch läuft?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von joker75 ()

  • So dann wollen wir das ganze mal zum Ende bringen.

    Nach diversen erfolglosen Versuchen habe ich es hinbekommen.

    Für alle die mit ähnlichen Problemen kämpfen hier die Variante die zum Teilerfolg geführt hat.

    Über die Oberfläche vom OMV lies sich der Plex nicht deinstallieren weil er ihn aus oben genanntem Grund nicht finden konnte.
    Also bin ich auf die Konsole und habe es via aptitude versucht.
    -- Nach "Plex" gesucht und die gefundenen Pakete, die auf Plex Mediaserver zurück zu führen waren, zum vollständigen entfernen vorgemerkt.
    -- Dann in der OMV Oberfläche den Plex-Server neu installiert.

    Jetzt war er erst mal wieder per Browser zu erreichen, natürlich ohne Datenbank.

    Nun kommt die Stelle mit dem Teilerfolg.

    Ich hatte mir vorher die Datenbank manuell gesichert und dachte wenn ich sie jetzt zurück schiebe ist alles wieder beim alten.
    Dem ist leider nicht so! Die Anzeige im Plex blieb leer, es wurden keine Mediatheken gefunden.

    Was Soll ich sagen, nach 24Std. scannen der neu angelegten Mediatheken und weiteren 4Std. nacharbeiten was beim Scannen falsch oder nicht erkannt wurde, ist nun wieder alles im lack.

    Da mir hier offensichtlich niemand helfen konnte habe ich die Hoffnung das evtl jemand mit ähnlichen Problemen hier auf meine Antwort stößt und ich so helfen kann,
  • Re,

    wie schon mehrfach in anderen Threads angemerkt, muss man beim Aktualisieren aufpassen, was man tut. Programmaktualisierung über die offiziellen Repo's haben nix mit "lokalen" Programmaktualisierungen zu tun - diese können das OMV-Ökosystem nachhaltig zerstören, denn OMV ist nur der Vermittler zw. dem System und der WebGUI. Wenn man dann Programme "hinten rum" aktualisiert, ohne den Vermittler anzupassen oder gar "Bescheid" zu sagen, darf man sich nicht wundern, das das gesamte Ökosystem seinen Dienst einstellt.

    In deinem Beispiel hat sicher die Aktualisierung vom (OMV-freundlichen) Plex auf eine neuere Version nicht nur die Datenbank aktualisiert (evtl. inkl neuem Format), sondern anscheinend auch den Webserver eine neu Konfigdatei untergeschoben ...

    Die gesicherte und zurück gespielte Datenbank sollte dennoch mit dem "alten" Plex funktionieren, i.d.R. muss man solche Datenbanken aber am Programm wieder anmelden (registrieren). Wie das bei Plex funktioniert weiß ich nicht - ich hoffe allerdings für Plex, das es eine Funktione zum exportieren der DB (aka zum Sichern) besitzt ... und natürlich dann auch eine Funktion, um die DB wieder zu importieren (das könnte auch mit deinen gesicherten Daten funktionieren).

    Sc0rp